Skip to content

← Actionable
Medium, CVSS 6.9amended

incorrect order of evaluation of side effects for some builtins

CVE-2023-41052GHSA-4hg4-9mf5-wxxq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vyper 0.3.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vyper

    Affected
    < 0.3.10
    Fixed in
    0.3.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-41052: 0.54% estimated exploitation activity in the next 30 days; percentile 45.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The order of evaluation of the arguments of the builtin functions uint256addmod, uint256mulmod, ecadd and ecmul does not follow source order. • For uint256addmod(a,b,c) and uint256mulmod(a,b,c), the order is c,a,b. • For ecadd(a,b) and ecmul(a,b), the order is b,a. Note that this behaviour is problematic when the evaluation of one of the arguments produces side effects that other arguments depend on. Patches https://github.com/vyperlang/vyper/pull/3583 Workarounds When using builtins from the list above, make sure that the arguments of the expression do not produce side effects or, if one does, that no other argument is dependent on those side effects.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4hg4-9mf5-wxxq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4hg4-9mf5-wxxq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-41052

Advisory: incorrect order of evaluation of side effects for some builtins
IDs: CVE-2023-41052, GHSA-4hg4-9mf5-wxxq
Record: https://patchnext.com/advisories/cve-2023-41052 (revision 3, source checked 26 Oct 2026, 13:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vyper 0.3.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vyper: affected < 0.3.10; fixed in 0.3.10

## Suggested inspection (read-only)
- `python -m pip show vyper`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vyper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4hg4-9mf5-wxxq (OSV record GHSA-4hg4-9mf5-wxxq lists affected ranges: PyPI vyper >=0 <0.3.10 (fixed))
- Verified: https://github.com/advisories/GHSA-4hg4-9mf5-wxxq (GitHub-reviewed advisory GHSA-4hg4-9mf5-wxxq lists affected ranges: PyPI vyper >=0 <0.3.10)

Commands are suggestions: review each one before running it.

Loading voting…