Information disclosure in AccessControl
CVE-2023-41050GHSA-8xv7-89vj-q48c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zope 5.8.4, 4.8.9; accesscontrol 6.2, 5.8, 4.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI zope
- Affected
- < 4.8.9>= 5.0.0, < 5.8.4
- Fixed in
- 4.8.9, 5.8.4
PyPI accesscontrol
- Affected
- < 4.4>= 5.0, < 5.8>= 6.0, < 6.2
- Fixed in
- 5.8, 6.2, 4.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8xv7-89vj-q48c lists affected ranges: PyPI accesscontrol >=0 =5.0 =6.0 =0 =5.0.0 <5.8.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8xv7-89vj-q48c lists affected ranges: PyPI accesscontrol >=0 =5.0 =6.0 =0 =5.0.0 <5.8.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2023-41050: 0.64% estimated exploitation activity in the next 30 days; percentile 50.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Python's "format" functionality allows someone controlling the format string to "read" objects accessible (recursively) via attribute access and subscription from accessible objects. Those attribute accesses and subscriptions use Python's full blown getattr and getitem, not the policy restricted AccessControl variants getattr and getitem. This can lead to critical information disclosure. AccessControl already provides a safe variant for str.format and denies access to string.Formatter. However, str.formatmap is still unsafe. Affected are all users who allow untrusted users to create AccessControl controlled Python code and execute it. Patches A fix will be introduced in the versions 4.4, 5.8 and 6.2. Workarounds There are no workarounds. References https://github.com/zopefoundation/RestrictedPython/security/advisories/GHSA-xjw2-6jm9-rf67 describes the corresponding problem for RestrictedPython.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-8xv7-89vj-q48c
- Revision 1 · created ·
Published from osv record GHSA-8xv7-89vj-q48c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-41050 Advisory: Information disclosure in AccessControl IDs: CVE-2023-41050, GHSA-8xv7-89vj-q48c Record: https://patchnext.com/advisories/cve-2023-41050 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zope 5.8.4, 4.8.9; accesscontrol 6.2, 5.8, 4.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI zope: affected < 4.8.9; >= 5.0.0, < 5.8.4; fixed in 4.8.9, 5.8.4 - PyPI accesscontrol: affected < 4.4; >= 5.0, < 5.8; >= 6.0, < 6.2; fixed in 5.8, 6.2, 4.4 ## Suggested inspection (read-only) - `python -m pip show zope`: prints the installed version. Run with the environment that serves production active. - `python -m pip show accesscontrol`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zope, accesscontrol. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-8xv7-89vj-q48c (OSV record GHSA-8xv7-89vj-q48c lists affected ranges: PyPI accesscontrol >=0 =5.0 =6.0 =0 =5.0.0 <5.8.4 (fixed)) - Verified: https://github.com/advisories/GHSA-8xv7-89vj-q48c (GitHub-reviewed advisory GHSA-8xv7-89vj-q48c lists affected ranges: PyPI accesscontrol >=0 =5.0 =6.0 =0 =5.0.0 <5.8.4) Commands are suggestions: review each one before running it.
Loading voting…