Mattermost fails to correctly delete attachments
CVE-2023-4105GHSA-g3v6-r8p9-wxg9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-server/v6 7.10.4, 7.9.6, 7.8.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost-server/v6
- Affected
- >= 7.9.0, <= 7.9.5>= 7.10.0, <= 7.10.3<= 7.8.7
- Fixed in
- 7.8.8, 7.9.6, 7.10.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g3v6-r8p9-wxg9 lists affected ranges: Go github.com/mattermost/mattermost-server/v6 >=7.9.0 =7.10.0 =0 <=7.8.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-4105: 0.40% estimated exploitation activity in the next 30 days; percentile 34.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost fails to delete the attachments when deleting a message in a thread allowing a simple user to still be able to access and download the attachment of a deleted message
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g3v6-r8p9-wxg9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-4105 Advisory: Mattermost fails to correctly delete attachments IDs: CVE-2023-4105, GHSA-g3v6-r8p9-wxg9 Record: https://patchnext.com/advisories/cve-2023-4105 (revision 1, source checked 26 Oct 2026, 15:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-server/v6 7.10.4, 7.9.6, 7.8.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost-server/v6: affected >= 7.9.0, <= 7.9.5; >= 7.10.0, <= 7.10.3; <= 7.8.7; fixed in 7.8.8, 7.9.6, 7.10.4 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost-server/v6: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost-server/v6. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g3v6-r8p9-wxg9 (GitHub-reviewed advisory GHSA-g3v6-r8p9-wxg9 lists affected ranges: Go github.com/mattermost/mattermost-server/v6 >=7.9.0 =7.10.0 =0 <=7.8.7) Commands are suggestions: review each one before running it.
Loading voting…