OctoPrint vulnerable to Improper Neutralization of Special Elements Used in a Template Engine
CVE-2023-41047GHSA-fwfg-vprh-97ph
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (octoprint 1.9.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI octoprint
- Affected
- < 1.9.3
- Fixed in
- 1.9.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fwfg-vprh-97ph lists affected ranges: PyPI octoprint >=0 <1.9.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fwfg-vprh-97ph lists affected ranges: PyPI octoprint >=0 <1.9.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-41047: 0.59% estimated exploitation activity in the next 30 days; percentile 48.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact OctoPrint versions up until and including 1.9.2 contain a vulnerability that allows malicious admins to configure a specially crafted GCODE script through the Settings that will allow code execution during rendering of that script. An attacker might use this to extract data managed by OctoPrint, or manipulate data managed by OctoPrint, as well as execute arbitrary commands with the rights of the OctoPrint process on the server system. Please note that GCODE files uploaded to be printed are not affected! This vulnerability exclusively affects GCODE Scripts to be executed on connection to the printer, print pause, resume etc, as described in the documentation, to be found under Settings GCODE Scripts and configurable only by users with the ADMIN permission. Patches The vulnerability has been patched in version 1.9.3. Workarounds OctoPrint administrators are strongly advised to thoroughly vet who has admin access to their installation and to not blindly configure arbitrary GCODE…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-fwfg-vprh-97ph
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-fwfg-vprh-97ph
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-41047 Advisory: OctoPrint vulnerable to Improper Neutralization of Special Elements Used in a Template Engine IDs: CVE-2023-41047, GHSA-fwfg-vprh-97ph Record: https://patchnext.com/advisories/cve-2023-41047 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: octoprint 1.9.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI octoprint: affected < 1.9.3; fixed in 1.9.3 ## Suggested inspection (read-only) - `python -m pip show octoprint`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on octoprint. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fwfg-vprh-97ph (OSV record GHSA-fwfg-vprh-97ph lists affected ranges: PyPI octoprint >=0 <1.9.3 (fixed)) - Verified: https://github.com/advisories/GHSA-fwfg-vprh-97ph (GitHub-reviewed advisory GHSA-fwfg-vprh-97ph lists affected ranges: PyPI octoprint >=0 <1.9.3) Commands are suggestions: review each one before running it.
Loading voting…