DDFFileParser is vulnerable to XXE Attacks
CVE-2023-41034GHSA-wc9j-gc65-3cm7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.leshan:leshan-core 2.0.0-M13, 1.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.eclipse.leshan:leshan-core
- Affected
- < 1.5.0>= 2.0.0-M1, < 2.0.0-M13
- Fixed in
- 1.5.0, 2.0.0-M13
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wc9j-gc65-3cm7 lists affected ranges: Maven org.eclipse.leshan:leshan-core >=0 =2.0.0-M1 <2.0.0-M13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2023-41034: 0.69% estimated exploitation activity in the next 30 days; percentile 52.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact DDFFileParser and DefaultDDFFileValidator (and so ObjectLoader) are vulnerable to XXE AttacksProcessing). DDF file is a LWM2M format used to store LWM2M object description. Leshan users are impacted only if they parse untrusted DDF files (e.g. if they let external users provide their own model), in that case they MUST upgrade to fixed version. If you parse only trusted DDF file and validate only with trusted xml schema, upgrading is not mandatory. Patches This is fixed in v1.5.0 and 2.0.0-M13. Workarounds No easy way. Eventually writing your own DDFFileParser/DefaultDDFFileValidator (and so ObjectLoader) creating a DocumentBuilderFactory with : References - https://owasp.org/www-community/vulnerabilities/XMLExternalEntity(XXE)Processing - https://cheatsheetseries.owasp.org/cheatsheets/XMLExternalEntityPreventionCheatSheet.html - https://semgrep.dev/docs/cheat-sheets/java-xxe/ - https://community.veracode.com/s/article/Java-Remediation-Guidance-for-XXE
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wc9j-gc65-3cm7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-41034 Advisory: DDFFileParser is vulnerable to XXE Attacks IDs: CVE-2023-41034, GHSA-wc9j-gc65-3cm7 Record: https://patchnext.com/advisories/cve-2023-41034 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.eclipse.leshan:leshan-core 2.0.0-M13, 1.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.eclipse.leshan:leshan-core: affected < 1.5.0; >= 2.0.0-M1, < 2.0.0-M13; fixed in 1.5.0, 2.0.0-M13 ## Suggested inspection (read-only) - Maven org.eclipse.leshan:leshan-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.eclipse.leshan:leshan-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wc9j-gc65-3cm7 (GitHub-reviewed advisory GHSA-wc9j-gc65-3cm7 lists affected ranges: Maven org.eclipse.leshan:leshan-core >=0 =2.0.0-M1 <2.0.0-M13) Commands are suggestions: review each one before running it.
Loading voting…