Skip to content

← Actionable
Medium, CVSS 6.5

wildfly-core Exposure of Sensitive Information to an Unauthorized Actor vulnerability

CVE-2023-4061GHSA-26qx-4m49-6cfr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.wildfly.core:wildfly-controller 22.0.0.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2023-4061: 1.04% estimated exploitation activity in the next 30 days; percentile 63.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A flaw was found in wildfly-core. A management user could use the resolve-expression in the HAL Interface to read possible sensitive information from the Wildfly system. This issue could allow a malicious user to access the system and obtain possible sensitive information from the system.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-26qx-4m49-6cfr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-4061

Advisory: wildfly-core Exposure of Sensitive Information to an Unauthorized Actor vulnerability
IDs: CVE-2023-4061, GHSA-26qx-4m49-6cfr
Record: https://patchnext.com/advisories/cve-2023-4061 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.wildfly.core:wildfly-controller 22.0.0.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.wildfly.core:wildfly-controller: affected < 22.0.0.Final; fixed in 22.0.0.Final

## Suggested inspection (read-only)
- Maven org.wildfly.core:wildfly-controller: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.wildfly.core:wildfly-controller.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-26qx-4m49-6cfr (GitHub-reviewed advisory GHSA-26qx-4m49-6cfr lists affected ranges: Maven org.wildfly.core:wildfly-controller >=0 <22.0.0.Final)

Commands are suggestions: review each one before running it.

Loading voting…