Skip to content

← Actionable
Medium, CVSS 6.5

Argo CD repo-server Denial of Service vulnerability

CVE-2023-40584GHSA-g687-f2gx-6wm8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/argoproj/argo-cd/v2 2.8.3, 2.7.14, 2.6.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-40584: 1.42% estimated exploitation activity in the next 30 days; percentile 72.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact All versions of ArgoCD starting from v2.4 have a bug where the ArgoCD repo-server component is vulnerable to a Denial-of-Service attack vector. Specifically, the said component extracts a user-controlled tar.gz file without validating the size of its inner files. As a result, a malicious, low-privileged user can send a malicious tar.gz file that exploits this vulnerability to the repo-server, thereby harming the system's functionality and availability. Additionally, the repo-server is susceptible to another vulnerability due to the fact that it does not check the extracted file permissions before attempting to delete them. Consequently, an attacker can craft a malicious tar.gz archive in a way that prevents the deletion of its inner files when the manifest generation process is completed. Patches A patch for this vulnerability has been released in the following Argo CD versions: v2.6.15 v2.7.14 v2.8.3 Workarounds The only way to completely resolve the issue is to upgrade.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g687-f2gx-6wm8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-40584

Advisory: Argo CD repo-server Denial of Service vulnerability
IDs: CVE-2023-40584, GHSA-g687-f2gx-6wm8
Record: https://patchnext.com/advisories/cve-2023-40584 (revision 1, source checked 26 Oct 2026, 15:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/argoproj/argo-cd/v2 2.8.3, 2.7.14, 2.6.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/argoproj/argo-cd/v2: affected >= 2.4.0, < 2.6.15; >= 2.7.0, < 2.7.14; >= 2.8.0, < 2.8.3; fixed in 2.8.3, 2.7.14, 2.6.15

## Suggested inspection (read-only)
- Go github.com/argoproj/argo-cd/v2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/argoproj/argo-cd/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g687-f2gx-6wm8 (GitHub-reviewed advisory GHSA-g687-f2gx-6wm8 lists affected ranges: Go github.com/argoproj/argo-cd/v2 >=2.4.0 =2.7.0 =2.8.0 <2.8.3)

Commands are suggestions: review each one before running it.

Loading voting…