Skip to content

← Actionable
High, CVSS 8.3amended

yt-dlp on Windows vulnerable to --exec command injection when using %q

CVE-2023-40581GHSA-42h4-v29r-42qg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yt-dlp 2023.9.24), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI yt-dlp

    Affected
    >= 2021.4.11, < 2023.9.24
    Fixed in
    2023.9.24

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-40581: 1.34% estimated exploitation activity in the next 30 days; percentile 71.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact yt-dlp allows the user to provide shell commands to be executed at various stages in its download process through the --exec flag. This flag allows output template expansion in its argument, so that video metadata values may be used in the shell commands. The metadata fields can be combined with the %q conversion, which is intended to quote/escape these values so they can be safely passed to the shell. However, the escaping used for cmd (the shell used by Python's subprocess on Windows) did not properly escape special characters, which can allow for remote code execution if --exec is used directly with maliciously crafted remote data. This vulnerability only impacts yt-dlp on Windows, and the vulnerability is present regardless of whether yt-dlp is run from cmd or from PowerShell. Support for output template expansion in --exec, along with this vulnerable behavior, was added to yt-dlp in version 2021.04.11. Patches yt-dlp version 2023.09.24 fixes this issue by properly…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-42h4-v29r-42qg

  2. Revision 1 · created ·

    Published from osv record GHSA-42h4-v29r-42qg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-40581

Advisory: yt-dlp on Windows vulnerable to `--exec` command injection when using `%q`
IDs: CVE-2023-40581, GHSA-42h4-v29r-42qg
Record: https://patchnext.com/advisories/cve-2023-40581 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yt-dlp 2023.9.24. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI yt-dlp: affected >= 2021.4.11, < 2023.9.24; fixed in 2023.9.24

## Suggested inspection (read-only)
- `python -m pip show yt-dlp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yt-dlp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-42h4-v29r-42qg (OSV record GHSA-42h4-v29r-42qg lists affected ranges: PyPI yt-dlp >=2021.04.11 <2023.09.24 (fixed))
- Verified: https://github.com/advisories/GHSA-42h4-v29r-42qg (GitHub-reviewed advisory GHSA-42h4-v29r-42qg lists affected ranges: PyPI yt-dlp >=2021.4.11 <2023.9.24)

Commands are suggestions: review each one before running it.

Loading voting…