Skip to content

← Actionable
Medium, CVSS 5.3amended

Datasette 1.0 alpha series leaks names of databases and tables to unauthenticated users

CVE-2023-40570GHSA-7ch3-7pp7-7cpq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (datasette 1.0a4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI datasette

    Affected
    >= 1.0a0, < 1.0a4
    Fixed in
    1.0a4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2023-40570: 0.56% estimated exploitation activity in the next 30 days; percentile 46.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This bug affects Datasette instances running a Datasette 1.0 alpha - 1.0a0, 1.0a1, 1.0a2 or 1.0a3 - in an online accessible location but with authentication enabled using a plugin such as datasette-auth-passwords. The /-/api API explorer endpoint could reveal the names of both databases and tables - but not their contents - to an unauthenticated user. Patches Datasette 1.0a4 has a fix for this issue. Workarounds To work around this issue, block all traffic to the /-/api endpoint. This can be done with a proxy such as Apache or NGINX, or by installing the datasette-block plugin and adding the following configuration to your metadata.json or metadata.yml file: This will block access to the API explorer but will still allow access to the Datasette read or write JSON APIs, as those use different URL patterns within the Datasette /database hierarchy.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7ch3-7pp7-7cpq

  2. Revision 1 · created ·

    Published from osv record GHSA-7ch3-7pp7-7cpq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-40570

Advisory: Datasette 1.0 alpha series leaks names of databases and tables to unauthenticated users
IDs: CVE-2023-40570, GHSA-7ch3-7pp7-7cpq
Record: https://patchnext.com/advisories/cve-2023-40570 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: datasette 1.0a4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI datasette: affected >= 1.0a0, < 1.0a4; fixed in 1.0a4

## Suggested inspection (read-only)
- `python -m pip show datasette`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on datasette.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7ch3-7pp7-7cpq (OSV record GHSA-7ch3-7pp7-7cpq lists affected ranges: PyPI datasette >=1.0a0 <1.0a4 (fixed))
- Verified: https://github.com/advisories/GHSA-7ch3-7pp7-7cpq (GitHub-reviewed advisory GHSA-7ch3-7pp7-7cpq lists affected ranges: PyPI datasette >=1.0a0 <1.0a4)

Commands are suggestions: review each one before running it.

Loading voting…