Jenkins Blue Ocean Plugin cross-site request forgery vulnerability
CVE-2023-40341GHSA-g4pq-p927-7pgg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.jenkins.blueocean:blueocean 1.27.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.jenkins.blueocean:blueocean
- Affected
- < 1.27.5.1
- Fixed in
- 1.27.5.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g4pq-p927-7pgg lists affected ranges: Maven io.jenkins.blueocean:blueocean >=0 <1.27.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2023-40341: 0.62% estimated exploitation activity in the next 30 days; percentile 49.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Blue Ocean Plugin 1.27.5 and earlier does not require POST requests for an HTTP endpoint, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to connect to an attacker-specified URL, capturing GitHub credentials associated with an attacker-specified job. This issue is due to an incomplete fix of SECURITY-2502. Blue Ocean Plugin 1.27.5.1 uses the configured SCM URL, instead of a user-specified URL provided as a parameter to the HTTP endpoint.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g4pq-p927-7pgg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-40341 Advisory: Jenkins Blue Ocean Plugin cross-site request forgery vulnerability IDs: CVE-2023-40341, GHSA-g4pq-p927-7pgg Record: https://patchnext.com/advisories/cve-2023-40341 (revision 1, source checked 26 Oct 2026, 16:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.jenkins.blueocean:blueocean 1.27.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.jenkins.blueocean:blueocean: affected < 1.27.5.1; fixed in 1.27.5.1 ## Suggested inspection (read-only) - Maven io.jenkins.blueocean:blueocean: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.jenkins.blueocean:blueocean. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g4pq-p927-7pgg (GitHub-reviewed advisory GHSA-g4pq-p927-7pgg lists affected ranges: Maven io.jenkins.blueocean:blueocean >=0 <1.27.5.1) Commands are suggestions: review each one before running it.
Loading voting…