Skip to content

← Actionable
Critical, CVSS 9.3amended

GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments

CVE-2023-40267GHSA-pr76-5cm5-w9cj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gitpython 3.1.32), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-40267: 1.18% estimated exploitation activity in the next 30 days; percentile 67.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

GitPython before 3.1.32 does not block insecure non-multi options in clone and clonefrom, making it vulnerable to Remote Code Execution (RCE) due to improper user input validation, which makes it possible to inject a maliciously crafted remote URL into the clone command. Exploiting this vulnerability is possible because the library makes external calls to git without sufficient sanitization of input arguments. NOTE: this issue exists because of an incomplete fix for CVE-2022-24439.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-pr76-5cm5-w9cj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-pr76-5cm5-w9cj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-40267

Advisory: GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments
IDs: CVE-2023-40267, GHSA-pr76-5cm5-w9cj
Record: https://patchnext.com/advisories/cve-2023-40267 (revision 3, source checked 26 Oct 2026, 13:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gitpython 3.1.32. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI gitpython: affected < 3.1.32; fixed in 3.1.32

## Suggested inspection (read-only)
- `python -m pip show gitpython`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gitpython.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pr76-5cm5-w9cj (OSV record GHSA-pr76-5cm5-w9cj lists affected ranges: PyPI gitpython >=0 <3.1.32 (fixed))
- Verified: https://github.com/advisories/GHSA-pr76-5cm5-w9cj (GitHub-reviewed advisory GHSA-pr76-5cm5-w9cj lists affected ranges: PyPI gitpython >=0 <3.1.32)

Commands are suggestions: review each one before running it.

Loading voting…