Skip to content

← Actionable
High, CVSS 7.5

Silverstripe GraphQL has DDOS Vulnerability due to lack of protection against recursive queries

CVE-2023-40180GHSA-v23w-pppm-jh66

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/graphql 5.0.3, 4.3.4, 4.2.5, 4.1.3, 3.8.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist silverstripe/graphql

    Affected
    >= 3.0.0, < 3.8.2>= 4.0.0, < 4.1.3>= 4.2.0, < 4.2.5>= 4.3.0, < 4.3.4>= 5.0.0, < 5.0.3
    Fixed in
    4.3.4, 4.1.3, 4.2.5, 5.0.3, 3.8.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-40180: 1.13% estimated exploitation activity in the next 30 days; percentile 66.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker could use a recursive graphql query to execute a Distributed Denial of Service attack (DDOS attack) against a website. This mostly affects websites with publicly exposed graphql schemas. If your Silverstripe CMS project does not expose a public facing graphql schema, a user account is required to trigger the DDOS attack. If your site is hosted behind a content delivery network (CDN), such as Imperva or CloudFlare, this may further mitigate the risk. The fix includes some new configuration options which you might want to tweak for your project, based on your own requirements. See the documentation in the references for details. Patches Patched in 3.8.2, 4.1.3, 4.2.5, 4.3.4, 5.0.3 References - CVE-2023-40180 on silverstripe.org - Documentation about protection against recursive or complex queries for silverstripe/graphql 4.x/5.x - Documentation about protection against recursive or complex queries for silverstripe/graphql 3.x Reported by Jason Nguyen from phew…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v23w-pppm-jh66

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-40180

Advisory: Silverstripe GraphQL has DDOS Vulnerability due to lack of protection against recursive queries
IDs: CVE-2023-40180, GHSA-v23w-pppm-jh66
Record: https://patchnext.com/advisories/cve-2023-40180 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/graphql 5.0.3, 4.3.4, 4.2.5, 4.1.3, 3.8.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/graphql: affected >= 3.0.0, < 3.8.2; >= 4.0.0, < 4.1.3; >= 4.2.0, < 4.2.5; >= 4.3.0, < 4.3.4; >= 5.0.0, < 5.0.3; fixed in 4.3.4, 4.1.3, 4.2.5, 5.0.3, 3.8.2

## Suggested inspection (read-only)
- Packagist silverstripe/graphql: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/graphql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v23w-pppm-jh66 (GitHub-reviewed advisory GHSA-v23w-pppm-jh66 lists affected ranges: Packagist silverstripe/graphql >=3.0.0 =4.0.0 =4.2.0 =4.3.0 =5.0.0 <5.0.3)

Commands are suggestions: review each one before running it.

Loading voting…