Skip to content

← Actionable
Medium, CVSS 5.3

Jetty accepts "+" prefixed value in Content-Length

CVE-2023-40167GHSA-hmr7-m48g-48f6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jetty:jetty-http 12.0.1, 11.0.16, 10.0.16, 9.4.52), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.eclipse.jetty:jetty-http

    Affected
    >= 9.0.0, <= 9.4.51>= 10.0.0, <= 10.0.15>= 11.0.0, <= 11.0.15>= 12.0.0, <= 12.0.0
    Fixed in
    9.4.52, 10.0.16, 11.0.16, 12.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2023-40167: 1.28% estimated exploitation activity in the next 30 days; percentile 70.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Jetty accepts the '+' character proceeding the content-length value in a HTTP/1 header field. This is more permissive than allowed by the RFC and other servers routinely reject such requests with 400 responses. There is no known exploit scenario, but it is conceivable that request smuggling could result if jetty is used in combination with a server that does not close the connection after sending such a 400 response. Workarounds There is no workaround as there is no known exploit scenario. Original Report RFC 9110 Secion 8.6 defined the value of Content-Length header should be a string of 0-9 digits. However we found that Jetty accepts "+" prefixed Content-Length, which could lead to potential HTTP request smuggling. Payload: When sending this payload to Jetty, it can successfully parse and identify the length. When sending this payload to NGINX, Apache HTTPd or other HTTP servers/parsers, they will return 400 bad request. This behavior can lead to HTTP request smuggling and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hmr7-m48g-48f6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-40167

Advisory: Jetty accepts "+" prefixed value in Content-Length
IDs: CVE-2023-40167, GHSA-hmr7-m48g-48f6
Record: https://patchnext.com/advisories/cve-2023-40167 (revision 1, source checked 26 Oct 2026, 16:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jetty:jetty-http 12.0.1, 11.0.16, 10.0.16, 9.4.52. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.eclipse.jetty:jetty-http: affected >= 9.0.0, <= 9.4.51; >= 10.0.0, <= 10.0.15; >= 11.0.0, <= 11.0.15; >= 12.0.0, <= 12.0.0; fixed in 9.4.52, 10.0.16, 11.0.16, 12.0.1

## Suggested inspection (read-only)
- Maven org.eclipse.jetty:jetty-http: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.eclipse.jetty:jetty-http.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hmr7-m48g-48f6 (GitHub-reviewed advisory GHSA-hmr7-m48g-48f6 lists affected ranges: Maven org.eclipse.jetty:jetty-http >=9.0.0 =10.0.0 =11.0.0 =12.0.0 <=12.0.0)

Commands are suggestions: review each one before running it.

Loading voting…