Craft CMS vulnerable to Remote Code Execution via validatePath bypass
CVE-2023-40035GHSA-44wr-rmwq-3phw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 4.4.15, 3.8.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 4.0.0-RC1, <= 4.4.14>= 3.0.0, <= 3.8.14
- Fixed in
- 3.8.15, 4.4.15
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-44wr-rmwq-3phw lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =3.0.0 <=3.8.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-40035: 2.32% estimated exploitation activity in the next 30 days; percentile 83.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Bypassing the validatePath function can lead to potential Remote Code Execution (Post-authentication, ALLOWADMINCHANGES=true) Details In bootstrap.php, the SystemPaths path is set as below. Because paths are validated based on the /path1/path2 format, this can be bypassed using a file URI scheme such as file:///path1/path2. File scheme is supported in mkdir() ref. https://www.php.net/manual/en/wrappers.file.php PoC 1) Create a new filesystem. Base Path: file:///var/www/html/templates 2) Create a new asset volume. Asset Filesystem: localbypass 3) Upload a ttml file with rce template code. Confirm poc.ttml file created in /var/www/html/templates 4) Create a new route. URI: , Template: poc.ttml 5) Confirm RCE on arbitrary path ( / ) PoC Env Impact Take control of vulnerable systems, Data exfiltrations, Malware execution, Pivoting, etc. although the vulnerability is exploitable only in the authenticated users, configuration with ALLOWADMINCHANGES=true, there is still a potential…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-44wr-rmwq-3phw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-40035 Advisory: Craft CMS vulnerable to Remote Code Execution via validatePath bypass IDs: CVE-2023-40035, GHSA-44wr-rmwq-3phw Record: https://patchnext.com/advisories/cve-2023-40035 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 4.4.15, 3.8.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 4.0.0-RC1, <= 4.4.14; >= 3.0.0, <= 3.8.14; fixed in 3.8.15, 4.4.15 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-44wr-rmwq-3phw (GitHub-reviewed advisory GHSA-44wr-rmwq-3phw lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =3.0.0 <=3.8.14) Commands are suggestions: review each one before running it.
Loading voting…