Skip to content

← Actionable
Medium, CVSS 4.9amended

Ghost vulnerable to arbitrary file read via symlinks in content import

CVE-2023-40028GHSA-9c9v-w225-v5rg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ghost 5.59.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ghost

    Affected
    < 5.59.1
    Fixed in
    5.59.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-40028: 68.95% estimated exploitation activity in the next 30 days; percentile 99.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability in Ghost allows authenticated users to upload files which are symlinks. This can be exploited to perform an arbitrary file read of any file on the operating system. Site administrators can check for exploitation of this issue by looking for unknown symlinks within Ghost's content/ folder Vulnerable versions This security vulnerability is present in Ghost ≤ v5.59.0. Patches v5.59.1 contains a fix for this issue. For more information If you have any questions or comments about this advisory: Email us at security@ghost.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9c9v-w225-v5rg

  2. Revision 1 · created ·

    Published from osv record GHSA-9c9v-w225-v5rg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-40028

Advisory: Ghost vulnerable to arbitrary file read via symlinks in content import
IDs: CVE-2023-40028, GHSA-9c9v-w225-v5rg
Record: https://patchnext.com/advisories/cve-2023-40028 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ghost 5.59.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ghost: affected < 5.59.1; fixed in 5.59.1

## Suggested inspection (read-only)
- `npm ls ghost --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ghost.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9c9v-w225-v5rg (OSV record GHSA-9c9v-w225-v5rg lists affected ranges: npm ghost >=0 <5.59.1 (fixed))
- Verified: https://github.com/advisories/GHSA-9c9v-w225-v5rg (GitHub-reviewed advisory GHSA-9c9v-w225-v5rg lists affected ranges: npm ghost >=0 <5.59.1)

Commands are suggestions: review each one before running it.

Loading voting…