When ui.isAccessAllowed is undefined, the adminMeta GraphQL query is publicly accessible
CVE-2023-40027GHSA-9cvc-v7wm-992c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@keystone-6/core 5.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @keystone-6/core
- Affected
- < 5.5.1
- Fixed in
- 5.5.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9cvc-v7wm-992c lists affected ranges: npm @keystone-6/core >=0 <5.5.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9cvc-v7wm-992c lists affected ranges: npm @keystone-6/core >=0 <5.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-40027: 0.58% estimated exploitation activity in the next 30 days; percentile 47.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When ui.isAccessAllowed is undefined, the adminMeta GraphQL query is publicly accessible, that is to say, no session is required for the query. This is different to the behaviour of the default AdminUI middleware, which by default will only be publicly accessible if a session strategy is not defined. Impact This vulnerability does not affect developers using the @keystone-6/auth package, or any users that have written their own ui.isAccessAllowed (that is to say, you are unaffected if ui.isAccessAllowed is defined). This vulnerability does affect developers who thought that their session strategy will, by default, enforce that adminMeta is inaccessible by the public in accordance with that strategy; akin to the behaviour of the AdminUI middleware. Patches This vulnerability has been patched in @keystone-6/core version 5.5.1. Workarounds You can opt to write your own isAccessAllowed to work-around this vulnerability. References Pull request…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9cvc-v7wm-992c
- Revision 1 · created ·
Published from osv record GHSA-9cvc-v7wm-992c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-40027 Advisory: When `ui.isAccessAllowed` is `undefined`, the `adminMeta` GraphQL query is publicly accessible IDs: CVE-2023-40027, GHSA-9cvc-v7wm-992c Record: https://patchnext.com/advisories/cve-2023-40027 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @keystone-6/core 5.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @keystone-6/core: affected < 5.5.1; fixed in 5.5.1 ## Suggested inspection (read-only) - `npm ls @keystone-6/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @keystone-6/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9cvc-v7wm-992c (OSV record GHSA-9cvc-v7wm-992c lists affected ranges: npm @keystone-6/core >=0 <5.5.1 (fixed)) - Verified: https://github.com/advisories/GHSA-9cvc-v7wm-992c (GitHub-reviewed advisory GHSA-9cvc-v7wm-992c lists affected ranges: npm @keystone-6/core >=0 <5.5.1) Commands are suggestions: review each one before running it.
Loading voting…