Scancode.io Reflected Cross-Site Scripting (XSS) in license endpoint
CVE-2023-40024GHSA-6xcx-gx7r-rccj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (scancodeio 32.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI scancodeio
- Affected
- <= 32.5.1
- Fixed in
- 32.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6xcx-gx7r-rccj lists affected ranges: PyPI scancodeio >=0 <32.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6xcx-gx7r-rccj lists affected ranges: PyPI scancodeio >=0 <=32.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-40024: 0.51% estimated exploitation activity in the next 30 days; percentile 43.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In the /license/ endpoint, the detailed view key is not properly validated and sanitized, which can result in a potential cross-site scripting (XSS) vulnerability when attempting to access a detailed license view that does not exist. Details In the /license/ endpoint, the licensedetailsview function is vulnerable to a potential cross-site scripting (XSS) attack due to inadequate validation and sanitization of the key parameter. This vulnerability arises when attempting to access a key with malicious javascript. PoC 1. Access following endpoint on scancode.io instance: http://localhost/license/%3Cscript%3Ealert(document.cookie);%3C/script%3E/ Impact Attackers can exploit the vulnerability to inject malicious scripts into the response generated by the licensedetailsview function. When unsuspecting users visit the page, their browsers will execute the injected scripts, leading to unauthorized actions, session hijacking, or stealing sensitive information.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6xcx-gx7r-rccj
- Revision 1 · created ·
Published from osv record GHSA-6xcx-gx7r-rccj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-40024 Advisory: Scancode.io Reflected Cross-Site Scripting (XSS) in license endpoint IDs: CVE-2023-40024, GHSA-6xcx-gx7r-rccj Record: https://patchnext.com/advisories/cve-2023-40024 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: scancodeio 32.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI scancodeio: affected <= 32.5.1; fixed in 32.5.2 ## Suggested inspection (read-only) - `python -m pip show scancodeio`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on scancodeio. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6xcx-gx7r-rccj (OSV record GHSA-6xcx-gx7r-rccj lists affected ranges: PyPI scancodeio >=0 <32.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-6xcx-gx7r-rccj (GitHub-reviewed advisory GHSA-6xcx-gx7r-rccj lists affected ranges: PyPI scancodeio >=0 <=32.5.1) Commands are suggestions: review each one before running it.
Loading voting…