Skip to content

← Actionable
High, CVSS 7.5

Yaklang Plugin's Fuzztag Component Allows Unauthorized Local File Reading

CVE-2023-40023GHSA-xvhg-w6qc-m3qq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/yaklang/yaklang 1.2.4-sp2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-40023: 1.05% estimated exploitation activity in the next 30 days; percentile 64.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Yak Engine has been found to contain a local file inclusion (LFI) vulnerability. This vulnerability allows attackers to include files from the server's local file system through the web application. When exploited, this can lead to the unintended exposure of sensitive data, potential remote code execution, or other security breaches. Users utilizing versions of the Yak Engine prior to 1.2.4-sp1 are impacted. Patches The vulnerability has been addressed and patched. Users are advised to upgrade to Yak Engine version 1.2.4-sp1 immediately. The patch can be viewed and reviewed at this PR: https://github.com/yaklang/yaklang/pull/295,https://github.com/yaklang/yaklang/pull/296 Workarounds Currently, the most effective solution is to upgrade to the patched version of Yak Engine (1.2.4-sp1). Users are also advised to avoid exposing vulnerable versions to untrusted input and to closely monitor any unexpected server behavior until they can upgrade. References For more details on…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xvhg-w6qc-m3qq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-40023

Advisory: Yaklang Plugin's Fuzztag Component Allows Unauthorized Local File Reading
IDs: CVE-2023-40023, GHSA-xvhg-w6qc-m3qq
Record: https://patchnext.com/advisories/cve-2023-40023 (revision 1, source checked 26 Oct 2026, 14:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/yaklang/yaklang 1.2.4-sp2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/yaklang/yaklang: affected < 1.2.4-sp2; fixed in 1.2.4-sp2

## Suggested inspection (read-only)
- Go github.com/yaklang/yaklang: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/yaklang/yaklang.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xvhg-w6qc-m3qq (GitHub-reviewed advisory GHSA-xvhg-w6qc-m3qq lists affected ranges: Go github.com/yaklang/yaklang >=0 <1.2.4-sp2)

Commands are suggestions: review each one before running it.

Loading voting…