GeoNode Server Side Request forgery
CVE-2023-40017GHSA-rmxg-6qqf-x8mr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (geonode 4.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI geonode
- Affected
- >= 3.2.0, < 4.2.0
- Fixed in
- 4.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rmxg-6qqf-x8mr lists affected ranges: PyPI geonode >=3.2.0 <4.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rmxg-6qqf-x8mr lists affected ranges: PyPI geonode >=3.2.0 <4.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-40017: 0.76% estimated exploitation activity in the next 30 days; percentile 55.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A server side request forgery vuln was found within geonode when testing on a bug bounty program. Server side request forgery allows a user to request information on the internal service/services. Details The endpoint /proxy/?url= does not properly protect against SSRF. when using the following format you can request internal hosts and display data. /proxy/?url=http://169.254.169.254\@whitelistedIPhere. This will state wether the AWS internal IP is alive. If you get a 404, the host is alive. A non alive host will not display a response. To display metadata, use a hashfrag on the url /proxy/?url=http://169.254.169.254\@#whitelisteddomain.com or try /proxy/?url=http://169.254.169.254\@%23whitelisteddomain.com Impact Port scan internal hosts, and request information from internal hosts.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rmxg-6qqf-x8mr
- Revision 1 · created ·
Published from osv record GHSA-rmxg-6qqf-x8mr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-40017 Advisory: GeoNode Server Side Request forgery IDs: CVE-2023-40017, GHSA-rmxg-6qqf-x8mr Record: https://patchnext.com/advisories/cve-2023-40017 (revision 2, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: geonode 4.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI geonode: affected >= 3.2.0, < 4.2.0; fixed in 4.2.0 ## Suggested inspection (read-only) - `python -m pip show geonode`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on geonode. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rmxg-6qqf-x8mr (OSV record GHSA-rmxg-6qqf-x8mr lists affected ranges: PyPI geonode >=3.2.0 <4.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rmxg-6qqf-x8mr (GitHub-reviewed advisory GHSA-rmxg-6qqf-x8mr lists affected ranges: PyPI geonode >=3.2.0 <4.2.0) Commands are suggestions: review each one before running it.
Loading voting…