Skip to content

← Actionable
Medium, CVSS 5.3amended

OpenZeppelin Contracts vulnerable to Improper Escaping of Output

CVE-2023-40014GHSA-g4vp-m682-qqmp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@openzeppelin/contracts 4.9.3; @openzeppelin/contracts-upgradeable 4.9.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2023-40014: 0.74% estimated exploitation activity in the next 30 days; percentile 54.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact OpenZeppelin Contracts is a library for secure smart contract development. Starting in version 4.0.0 and prior to version 4.9.3, contracts using ERC2771Context along with a custom trusted forwarder may see msgSender return address(0) in calls that originate from the forwarder with calldata shorter than 20 bytes. This combination of circumstances does not appear to be common, in particular it is not the case for MinimalForwarder from OpenZeppelin Contracts, or any deployed forwarder the team is aware of, given that the signer address is appended to all calls that originate from these forwarders. Patches The problem has been patched in v4.9.3.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g4vp-m682-qqmp

  2. Revision 1 · created ·

    Published from osv record GHSA-g4vp-m682-qqmp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-40014

Advisory: OpenZeppelin Contracts vulnerable to Improper Escaping of Output
IDs: CVE-2023-40014, GHSA-g4vp-m682-qqmp
Record: https://patchnext.com/advisories/cve-2023-40014 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @openzeppelin/contracts 4.9.3; @openzeppelin/contracts-upgradeable 4.9.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @openzeppelin/contracts: affected >= 4.0.0, < 4.9.3; fixed in 4.9.3
- npm @openzeppelin/contracts-upgradeable: affected >= 4.0.0, < 4.9.3; fixed in 4.9.3

## Suggested inspection (read-only)
- `npm ls @openzeppelin/contracts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @openzeppelin/contracts-upgradeable --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @openzeppelin/contracts, @openzeppelin/contracts-upgradeable.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g4vp-m682-qqmp (OSV record GHSA-g4vp-m682-qqmp lists affected ranges: npm @openzeppelin/contracts >=4.0.0 =4.0.0 <4.9.3 (fixed))
- Verified: https://github.com/advisories/GHSA-g4vp-m682-qqmp (GitHub-reviewed advisory GHSA-g4vp-m682-qqmp lists affected ranges: npm @openzeppelin/contracts >=4.0.0 =4.0.0 <4.9.3)

Commands are suggestions: review each one before running it.

Loading voting…