external-svg-loader Cross-site Scripting vulnerability
CVE-2023-40013GHSA-xc2r-jf2x-gjr8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (external-svg-loader 1.6.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.6.9
- Fixed in
- 1.6.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xc2r-jf2x-gjr8 lists affected ranges: npm external-svg-loader >=0 <1.6.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xc2r-jf2x-gjr8 lists affected ranges: npm external-svg-loader >=0 <1.6.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-40013: 0.56% estimated exploitation activity in the next 30 days; percentile 46.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary According to the docs, svg-loader will strip all JS code before injecting the SVG file for security reasons but the input sanitization logic is not sufficient and can be trivially bypassed. This allows an attacker to craft a malicious SVG which can result in XSS. Details When trying to sanitize the svg the lib removes event attributes such as onmouseover, onclick but the list of events is not exhaustive. Here's a list of events not removed by svg-loader. onafterscriptexecute, onbeforecopy, onbeforecut, onbeforescriptexecute, onbeforetoggle, onbegin, onbounce, onend, onfinish, onfocusin, onfocusout, onmousewheel, onpointerrawupdate, onrepeat, onsearch, onshow, onstart, ontoggle(popover), ontouchend, ontouchmove, ontouchstart As you can see in the POC we can use onbegin in animate tag to execute JS code without needing to add data-js="enabled". PoC Impact Any website which uses external-svg-loader and allows its users to provide svg src, upload svg files would be susceptible to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xc2r-jf2x-gjr8
- Revision 1 · created ·
Published from osv record GHSA-xc2r-jf2x-gjr8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-40013 Advisory: external-svg-loader Cross-site Scripting vulnerability IDs: CVE-2023-40013, GHSA-xc2r-jf2x-gjr8 Record: https://patchnext.com/advisories/cve-2023-40013 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: external-svg-loader 1.6.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm external-svg-loader: affected < 1.6.9; fixed in 1.6.9 ## Suggested inspection (read-only) - `npm ls external-svg-loader --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on external-svg-loader. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xc2r-jf2x-gjr8 (OSV record GHSA-xc2r-jf2x-gjr8 lists affected ranges: npm external-svg-loader >=0 <1.6.9 (fixed)) - Verified: https://github.com/advisories/GHSA-xc2r-jf2x-gjr8 (GitHub-reviewed advisory GHSA-xc2r-jf2x-gjr8 lists affected ranges: npm external-svg-loader >=0 <1.6.9) Commands are suggestions: review each one before running it.
Loading voting…