Open Redirect Vulnerability in jupyter-server
CVE-2023-39968GHSA-r726-vmfq-j9j3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-server 2.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyter-server
- Affected
- < 2.7.2
- Fixed in
- 2.7.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r726-vmfq-j9j3 lists affected ranges: PyPI jupyter-server >=0 <2.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r726-vmfq-j9j3 lists affected ranges: PyPI jupyter-server >=0 <2.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2023-39968: 0.68% estimated exploitation activity in the next 30 days; percentile 52.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Open Redirect Vulnerability. Maliciously crafted login links to known Jupyter Servers can cause successful login or an already logged-in session to be redirected to arbitrary sites, which should be restricted to Jupyter Server-served URLs. Patches Upgrade to Jupyter Server 2.7.2 Workarounds None. References Vulnerability reported by user davwwwx via the bug bounty program sponsored by the European Commission and hosted on the Intigriti platform. - https://blog.xss.am/2023/08/cve-2023-39968-jupyter-token-leak/
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-r726-vmfq-j9j3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-r726-vmfq-j9j3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-39968 Advisory: Open Redirect Vulnerability in jupyter-server IDs: CVE-2023-39968, GHSA-r726-vmfq-j9j3 Record: https://patchnext.com/advisories/cve-2023-39968 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyter-server 2.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyter-server: affected < 2.7.2; fixed in 2.7.2 ## Suggested inspection (read-only) - `python -m pip show jupyter-server`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyter-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r726-vmfq-j9j3 (OSV record GHSA-r726-vmfq-j9j3 lists affected ranges: PyPI jupyter-server >=0 <2.7.2 (fixed)) - Verified: https://github.com/advisories/GHSA-r726-vmfq-j9j3 (GitHub-reviewed advisory GHSA-r726-vmfq-j9j3 lists affected ranges: PyPI jupyter-server >=0 <2.7.2) Commands are suggestions: review each one before running it.
Loading voting…