1Panel arbitrary file write vulnerability
CVE-2023-39966GHSA-hf7j-xj3w-87g4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/1Panel-dev/1Panel 1.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/1Panel-dev/1Panel
- Affected
- >= 1.4.3, <= 1.4.3
- Fixed in
- 1.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hf7j-xj3w-87g4 lists affected ranges: Go github.com/1Panel-dev/1Panel >=1.4.3 <=1.4.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2023-39966: 0.83% estimated exploitation activity in the next 30 days; percentile 57.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An arbitrary file write vulnerability could lead to direct control of the server Details Arbitrary file creation In the api/v1/file.go file, there is a function called SaveContentthat,It recieves JSON data sent by users in the form of a POST request. And the lack of parameter filtering allows for arbitrary file write operations.It looks like this: - Vulnerable Code PoC - We can write the SSH public key into the /etc/.root/authorizedkeys configuration file on the server. - The server was successfully written to the public key - Successfully connected to the target server using an SSH private key. As a result, the server is directly controlled, causing serious harm Impact 1Panel v1.4.3
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hf7j-xj3w-87g4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-39966 Advisory: 1Panel arbitrary file write vulnerability IDs: CVE-2023-39966, GHSA-hf7j-xj3w-87g4 Record: https://patchnext.com/advisories/cve-2023-39966 (revision 1, source checked 26 Oct 2026, 15:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/1Panel-dev/1Panel 1.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/1Panel-dev/1Panel: affected >= 1.4.3, <= 1.4.3; fixed in 1.5.0 ## Suggested inspection (read-only) - Go github.com/1Panel-dev/1Panel: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/1Panel-dev/1Panel. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hf7j-xj3w-87g4 (GitHub-reviewed advisory GHSA-hf7j-xj3w-87g4 lists affected ranges: Go github.com/1Panel-dev/1Panel >=1.4.3 <=1.4.3) Commands are suggestions: review each one before running it.
Loading voting…