NLnet Labs’ Routinator vulnerable to path traversal
CVE-2023-39916GHSA-5rxf-fqch-7vqp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (routinator 0.12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io routinator
- Affected
- >= 0.9.0, < 0.12.2
- Fixed in
- 0.12.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5rxf-fqch-7vqp lists affected ranges: crates.io routinator >=0.9.0 <0.12.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:H
- EPSS
- CVE-2023-39916: 0.64% estimated exploitation activity in the next 30 days; percentile 50.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
NLnet Labs’ Routinator 0.9.0 up to and including 0.12.1 contains a possible path traversal vulnerability in the optional, off-by-default keep-rrdp-responses feature that allows users to store the content of responses received for RRDP requests. The location of these stored responses is constructed from the URL of the request. Due to insufficient sanitation of the URL, it is possible for an attacker to craft a URL that results in the response being stored outside of the directory specified for it.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5rxf-fqch-7vqp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-39916 Advisory: NLnet Labs’ Routinator vulnerable to path traversal IDs: CVE-2023-39916, GHSA-5rxf-fqch-7vqp Record: https://patchnext.com/advisories/cve-2023-39916 (revision 1, source checked 26 Oct 2026, 15:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: routinator 0.12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io routinator: affected >= 0.9.0, < 0.12.2; fixed in 0.12.2 ## Suggested inspection (read-only) - crates.io routinator: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on routinator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5rxf-fqch-7vqp (GitHub-reviewed advisory GHSA-5rxf-fqch-7vqp lists affected ranges: crates.io routinator >=0.9.0 <0.12.2) Commands are suggestions: review each one before running it.
Loading voting…