pandasai vulnerable to prompt injection
CVE-2023-39660GHSA-w832-v3c6-m6rg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pandasai 0.8.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pandasai
- Affected
- < 0.8.1
- Fixed in
- 0.8.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w832-v3c6-m6rg lists affected ranges: PyPI pandasai >=0 <0.8.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w832-v3c6-m6rg lists affected ranges: PyPI pandasai >=0 <0.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2023-39660: 1.53% estimated exploitation activity in the next 30 days; percentile 74.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue in Gaberiele Venturi pandasai v.0.8.0 and before allows a remote attacker to execute arbitrary code via a crafted request to the prompt function.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w832-v3c6-m6rg
- Revision 1 · created ·
Published from osv record GHSA-w832-v3c6-m6rg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-39660 Advisory: pandasai vulnerable to prompt injection IDs: CVE-2023-39660, GHSA-w832-v3c6-m6rg Record: https://patchnext.com/advisories/cve-2023-39660 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pandasai 0.8.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pandasai: affected < 0.8.1; fixed in 0.8.1 ## Suggested inspection (read-only) - `python -m pip show pandasai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pandasai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w832-v3c6-m6rg (OSV record GHSA-w832-v3c6-m6rg lists affected ranges: PyPI pandasai >=0 <0.8.1 (fixed)) - Verified: https://github.com/advisories/GHSA-w832-v3c6-m6rg (GitHub-reviewed advisory GHSA-w832-v3c6-m6rg lists affected ranges: PyPI pandasai >=0 <0.8.1) Commands are suggestions: review each one before running it.
Loading voting…