Skip to content

← Actionable
High, CVSS 8.7amended

apache-airflow-providers-apache-drill Improper Input Validation vulnerability

CVE-2023-39553GHSA-mq4v-6vg4-796c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-providers-apache-drill 2.4.3; apache-airflow 2.4.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-39553: 2.28% estimated exploitation activity in the next 30 days; percentile 83.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Drill Provider. Apache Airflow Drill Provider is affected by a vulnerability that allows an attacker to pass in malicious parameters when establishing a connection with DrillHook giving an opportunity to read files on the Airflow server. This issue affects Apache Airflow Drill Provider before 2.4.3. It is recommended to upgrade to a version that is not affected.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-mq4v-6vg4-796c

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record PYSEC-2023-136

  4. Revision 1 · created ·

    Published from osv record GHSA-mq4v-6vg4-796c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-39553

Advisory: apache-airflow-providers-apache-drill Improper Input Validation vulnerability
IDs: CVE-2023-39553, GHSA-mq4v-6vg4-796c
Record: https://patchnext.com/advisories/cve-2023-39553 (revision 4, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow-providers-apache-drill 2.4.3; apache-airflow 2.4.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow-providers-apache-drill: affected < 2.4.3; fixed in 2.4.3
- PyPI apache-airflow: affected < 2.4.3; fixed in 2.4.3

## Suggested inspection (read-only)
- `python -m pip show apache-airflow-providers-apache-drill`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow-providers-apache-drill, apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mq4v-6vg4-796c (OSV record GHSA-mq4v-6vg4-796c lists affected ranges: PyPI apache-airflow-providers-apache-drill >=0 <2.4.3 (fixed))
- Verified: https://osv.dev/vulnerability/PYSEC-2023-136 (OSV record PYSEC-2023-136 lists affected ranges: PyPI apache-airflow >=0 <2.4.3 (fixed))
- Verified: https://github.com/advisories/GHSA-mq4v-6vg4-796c (GitHub-reviewed advisory GHSA-mq4v-6vg4-796c lists affected ranges: PyPI apache-airflow-providers-apache-drill >=0 <2.4.3)

Commands are suggestions: review each one before running it.

Loading voting…