Skip to content

← Actionable
Critical, CVSS 9.8amended

SES's dynamic import and spread operator provides possible path to arbitrary exfiltration and execution

CVE-2023-39532GHSA-9c4h-3f7h-322r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ses 0.18.7, 0.17.1, 0.16.1, 0.15.24, 0.14.5, 0.13.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ses

    Affected
    >= 0.13.0, < 0.13.5>= 0.14.0, < 0.14.5>= 0.15.0, < 0.15.24>= 0.16.0, <= 0.16.0>= 0.17.0, <= 0.17.0>= 0.18.0, < 0.18.7
    Fixed in
    0.15.24, 0.14.5, 0.17.1, 0.18.7, 0.13.5, 0.16.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-39532: 1.35% estimated exploitation activity in the next 30 days; percentile 71.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This is a hole in the confinement of guest applications under SES that may manifest as either the ability to exfiltrate information or execute arbitrary code depending on the configuration and implementation of the surrounding host. Guest program running inside a Compartment with as few as no endowments can gain access to the surrounding host’s dynamic import by using dynamic import after the spread operator, like {...import(arbitraryModuleSpecifier)}. On the web or in web extensions, a Content-Security-Policy following ordinary best practices likely mitigates both the risk of exfiltration and execution of arbitrary code, at least limiting the modules that the attacker can import to those that are already part of the application. However, without a Content-Security-Policy, dynamic import can be used to issue HTTP requests for either communication through the URL or for the execution of code reachable from that origin. Within an XS worker, an attacker can use the host’s module…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9c4h-3f7h-322r

  2. Revision 1 · created ·

    Published from osv record GHSA-9c4h-3f7h-322r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-39532

Advisory: SES's dynamic import and spread operator provides possible path to arbitrary exfiltration and execution
IDs: CVE-2023-39532, GHSA-9c4h-3f7h-322r
Record: https://patchnext.com/advisories/cve-2023-39532 (revision 2, source checked 26 Oct 2026, 12:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ses 0.18.7, 0.17.1, 0.16.1, 0.15.24, 0.14.5, 0.13.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ses: affected >= 0.13.0, < 0.13.5; >= 0.14.0, < 0.14.5; >= 0.15.0, < 0.15.24; >= 0.16.0, <= 0.16.0; >= 0.17.0, <= 0.17.0; >= 0.18.0, < 0.18.7; fixed in 0.15.24, 0.14.5, 0.17.1, 0.18.7, 0.13.5, 0.16.1

## Suggested inspection (read-only)
- `npm ls ses --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ses.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9c4h-3f7h-322r (OSV record GHSA-9c4h-3f7h-322r lists affected ranges: npm ses >=0.13.0 =0.14.0 =0.15.0 =0.16.0 =0.17.0 =0.18.0 <0.18.7 (fixed))
- Verified: https://github.com/advisories/GHSA-9c4h-3f7h-322r (GitHub-reviewed advisory GHSA-9c4h-3f7h-322r lists affected ranges: npm ses >=0.13.0 =0.14.0 =0.15.0 =0.16.0 =0.17.0 =0.18.0 <0.18.7)

Commands are suggestions: review each one before running it.

Loading voting…