Sentry vulnerable to incorrect credential validation on OAuth token requests
CVE-2023-39531GHSA-hgj4-h2x3-rfx4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sentry 23.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI sentry
- Affected
- >= 10.0.0, < 23.7.2
- Fixed in
- 23.7.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hgj4-h2x3-rfx4 lists affected ranges: PyPI sentry >=10.0.0 <23.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hgj4-h2x3-rfx4 lists affected ranges: PyPI sentry >=10.0.0 <23.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:L/A:N
- EPSS
- CVE-2023-39531: 0.36% estimated exploitation activity in the next 30 days; percentile 29.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker with sufficient client-side exploits could retrieve a valid access token for another user during the OAuth token exchange due to incorrect credential validation. The client ID must be known and the API application must have already been authorized on the targeted user account. Remediation - Sentry SaaS customers do not need to take any action. Those with the highest risk will be contacted directly by Sentry. - Self-hosted installations should upgrade to version 23.7.2 or higher. Workarounds There are no direct workarounds, but users should review applications authorized on their account (User Settings Authorized Applications) and remove any that are no longer needed.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hgj4-h2x3-rfx4
- Revision 1 · created ·
Published from osv record GHSA-hgj4-h2x3-rfx4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-39531 Advisory: Sentry vulnerable to incorrect credential validation on OAuth token requests IDs: CVE-2023-39531, GHSA-hgj4-h2x3-rfx4 Record: https://patchnext.com/advisories/cve-2023-39531 (revision 2, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sentry 23.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI sentry: affected >= 10.0.0, < 23.7.2; fixed in 23.7.2 ## Suggested inspection (read-only) - `python -m pip show sentry`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sentry. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hgj4-h2x3-rfx4 (OSV record GHSA-hgj4-h2x3-rfx4 lists affected ranges: PyPI sentry >=10.0.0 <23.7.2 (fixed)) - Verified: https://github.com/advisories/GHSA-hgj4-h2x3-rfx4 (GitHub-reviewed advisory GHSA-hgj4-h2x3-rfx4 lists affected ranges: PyPI sentry >=10.0.0 <23.7.2) Commands are suggestions: review each one before running it.
Loading voting…