PrestaShop XSS injection through Validate::isCleanHTML method
CVE-2023-39527GHSA-xw2r-f8xv-c8xp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (prestashop/prestashop 8.1.1, 8.0.5, 1.7.8.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist prestashop/prestashop
- Affected
- >= 8.1.0, <= 8.1.0>= 8.0.0, < 8.0.5< 1.7.8.10
- Fixed in
- 8.1.1, 1.7.8.10, 8.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xw2r-f8xv-c8xp lists affected ranges: Packagist prestashop/prestashop >=8.1.0 =8.0.0 =0 <1.7.8.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:H/A:H
- EPSS
- CVE-2023-39527: 0.51% estimated exploitation activity in the next 30 days; percentile 43.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact xss injection through isCleanHTML method Patches 1.7.8.10 8.0.5 8.1.1 Found by Aleksey Solovev (Positive Technologies) Workarounds References
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xw2r-f8xv-c8xp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-39527 Advisory: PrestaShop XSS injection through Validate::isCleanHTML method IDs: CVE-2023-39527, GHSA-xw2r-f8xv-c8xp Record: https://patchnext.com/advisories/cve-2023-39527 (revision 1, source checked 26 Oct 2026, 14:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: prestashop/prestashop 8.1.1, 8.0.5, 1.7.8.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist prestashop/prestashop: affected >= 8.1.0, <= 8.1.0; >= 8.0.0, < 8.0.5; < 1.7.8.10; fixed in 8.1.1, 1.7.8.10, 8.0.5 ## Suggested inspection (read-only) - Packagist prestashop/prestashop: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on prestashop/prestashop. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xw2r-f8xv-c8xp (GitHub-reviewed advisory GHSA-xw2r-f8xv-c8xp lists affected ranges: Packagist prestashop/prestashop >=8.1.0 =8.0.0 =0 <1.7.8.10) Commands are suggestions: review each one before running it.
Loading voting…