Apache Avro Java SDK vulnerable to Improper Input Validation
CVE-2023-39410GHSA-rhrv-645h-fjfh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.avro:avro 1.11.3; avro 1.11.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.avro:avro
- Affected
- < 1.11.3
- Fixed in
- 1.11.3
PyPI avro
- Affected
- < 1.11.3
- Fixed in
- 1.11.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2023-188 lists affected ranges: PyPI avro >=0 <1.11.3 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rhrv-645h-fjfh lists affected ranges: Maven org.apache.avro:avro >=0 <1.11.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-39410: 2.22% estimated exploitation activity in the next 30 days; percentile 82.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When deserializing untrusted or corrupted data, it is possible for a reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system. This issue affects Java applications using Apache Avro Java SDK up to and including 1.11.2. Users should update to apache-avro version 1.11.3 which addresses this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rhrv-645h-fjfh
- Revision 1 · created ·
Published from osv record PYSEC-2023-188
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-39410 Advisory: Apache Avro Java SDK vulnerable to Improper Input Validation IDs: CVE-2023-39410, GHSA-rhrv-645h-fjfh Record: https://patchnext.com/advisories/cve-2023-39410 (revision 2, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.avro:avro 1.11.3; avro 1.11.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.avro:avro: affected < 1.11.3; fixed in 1.11.3 - PyPI avro: affected < 1.11.3; fixed in 1.11.3 ## Suggested inspection (read-only) - Maven org.apache.avro:avro: check the installed version with your package manager. - `python -m pip show avro`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.avro:avro, avro. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2023-188 (OSV record PYSEC-2023-188 lists affected ranges: PyPI avro >=0 <1.11.3 (fixed)) - Verified: https://github.com/advisories/GHSA-rhrv-645h-fjfh (GitHub-reviewed advisory GHSA-rhrv-645h-fjfh lists affected ranges: Maven org.apache.avro:avro >=0 <1.11.3) Commands are suggestions: review each one before running it.
Loading voting…