Skip to content

← Actionable
Critical, CVSS 9.1amended

Vyper has incorrectly allocated named re-entrancy locks

CVE-2023-39363GHSA-5824-cm3x-3c38

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vyper 0.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vyper

    Affected
    >= 0.2.15, < 0.3.1
    Fixed in
    0.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H/E:A · score source
EPSS
  • CVE-2023-39363: 0.82% estimated exploitation activity in the next 30 days; percentile 57.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In versions 0.2.15, 0.2.16 and 0.3.0, named re-entrancy locks are allocated incorrectly. Each function using a named re-entrancy lock gets a unique lock regardless of the key, allowing cross-function re-entrancy in contracts compiled with the susceptible versions. A specific set of conditions is required to result in misbehavior of affected contracts, specifically: - A .vy contract compiled with either of the following vyper versions: 0.2.15, 0.2.16, 0.3.0 - A primary function that utilizes the @nonreentrant decorator with a specific key and does not strictly follow the check-effects-interaction pattern (i.e. contains an external call to an untrusted party before storage updates) - A secondary function that utilizes the same key and would be affected by the improper state caused by the primary function Patches https://github.com/vyperlang/vyper/pull/2439, https://github.com/vyperlang/vyper/pull/2514 Workarounds Upgrade to 0.3.1 or higher References Technical post-mortem…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5824-cm3x-3c38

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5824-cm3x-3c38

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-39363

Advisory: Vyper has incorrectly allocated named re-entrancy locks
IDs: CVE-2023-39363, GHSA-5824-cm3x-3c38
Record: https://patchnext.com/advisories/cve-2023-39363 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vyper 0.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vyper: affected >= 0.2.15, < 0.3.1; fixed in 0.3.1

## Suggested inspection (read-only)
- `python -m pip show vyper`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vyper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5824-cm3x-3c38 (OSV record GHSA-5824-cm3x-3c38 lists affected ranges: PyPI vyper >=0.2.15 <0.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-5824-cm3x-3c38 (GitHub-reviewed advisory GHSA-5824-cm3x-3c38 lists affected ranges: PyPI vyper >=0.2.15 <0.3.1)

Commands are suggestions: review each one before running it.

Loading voting…