Skip to content

← Actionable
Medium, CVSS 5.4

Kubernetes users may update Pod labels to bypass network policy

CVE-2023-39347GHSA-gj2r-phwg-6rww

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cilium/cilium 1.14.2, 1.13.7, 1.12.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:L
EPSS
  • CVE-2023-39347: 0.57% estimated exploitation activity in the next 30 days; percentile 47.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker with the ability to update pod labels can cause Cilium to apply incorrect network policies. This issue arises due to the fact that on pod update, Cilium incorrectly uses user-provided pod labels to select the policies which apply to the workload in question. This can affect: Cilium network policies that use the namespace, service account or cluster constructs to restrict traffic Cilium clusterwide network policies that use Cilium namespace labels to select the Pod Kubernetes network policies Non-existent construct names can be provided, which bypass all network policies applicable to the construct. For example, providing a pod with a non-existent namespace as the value of the io.kubernetes.pod.namespace label results in none of the namespaced CiliumNetworkPolicies applying to the pod in question. This attack requires the attacker to have Kubernetes API Server access, as described in the Cilium Threat Model. Patches This issue affects: - Cilium <= v1.14.1 - Cilium…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gj2r-phwg-6rww

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-39347

Advisory: Kubernetes users may update Pod labels to bypass network policy
IDs: CVE-2023-39347, GHSA-gj2r-phwg-6rww
Record: https://patchnext.com/advisories/cve-2023-39347 (revision 1, source checked 26 Oct 2026, 15:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/cilium/cilium 1.14.2, 1.13.7, 1.12.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/cilium/cilium: affected >= 1.13.0, <= 1.13.6; >= 1.14.0, <= 1.14.1; <= 1.12.13; fixed in 1.12.14, 1.14.2, 1.13.7

## Suggested inspection (read-only)
- Go github.com/cilium/cilium: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/cilium/cilium.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gj2r-phwg-6rww (GitHub-reviewed advisory GHSA-gj2r-phwg-6rww lists affected ranges: Go github.com/cilium/cilium >=1.13.0 =1.14.0 =0 <=1.12.13)

Commands are suggestions: review each one before running it.

Loading voting…