Unauthorized Access to Private Fields in User Registration API
CVE-2023-39345GHSA-gc7p-j5xm-xxh2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/plugin-users-permissions 4.13.1; @strapi/strapi 4.13.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @strapi/plugin-users-permissions
- Affected
- >= 4.0.0, < 4.13.1
- Fixed in
- 4.13.1
npm @strapi/strapi
- Affected
- >= 4.0.0, < 4.13.1
- Fixed in
- 4.13.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gc7p-j5xm-xxh2 lists affected ranges: npm @strapi/plugin-users-permissions >=4.0.0 =4.0.0 <4.13.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gc7p-j5xm-xxh2 lists affected ranges: npm @strapi/plugin-users-permissions >=4.0.0 =4.0.0 <4.13.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L
- EPSS
- CVE-2023-39345: 0.59% estimated exploitation activity in the next 30 days; percentile 48.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
System Details | Name | Value | |----------|------------------------| | OS | Windows 11 | | Version | 4.11.1 (node v16.14.2) | | Database | mysql | Description I marked some fields as private fields in user content-type, and tried to register as a new user via api, at the same time I added content to fill the private fields and sent a post request, and as you can see from the images below, I can write to the private fields. To prevent this, I went to the extension area and tried to extend the register method, for this I wanted to do it using the sanitizeInput function that I know in the source codes of the strap. But the sanitizeInput function did not filter out private fields. here's the solution I've temporarily kept to myself, code snippet
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gc7p-j5xm-xxh2
- Revision 1 · created ·
Published from osv record GHSA-gc7p-j5xm-xxh2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-39345 Advisory: Unauthorized Access to Private Fields in User Registration API IDs: CVE-2023-39345, GHSA-gc7p-j5xm-xxh2 Record: https://patchnext.com/advisories/cve-2023-39345 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @strapi/plugin-users-permissions 4.13.1; @strapi/strapi 4.13.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @strapi/plugin-users-permissions: affected >= 4.0.0, < 4.13.1; fixed in 4.13.1 - npm @strapi/strapi: affected >= 4.0.0, < 4.13.1; fixed in 4.13.1 ## Suggested inspection (read-only) - `npm ls @strapi/plugin-users-permissions --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @strapi/strapi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @strapi/plugin-users-permissions, @strapi/strapi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gc7p-j5xm-xxh2 (OSV record GHSA-gc7p-j5xm-xxh2 lists affected ranges: npm @strapi/plugin-users-permissions >=4.0.0 =4.0.0 <4.13.1 (fixed)) - Verified: https://github.com/advisories/GHSA-gc7p-j5xm-xxh2 (GitHub-reviewed advisory GHSA-gc7p-j5xm-xxh2 lists affected ranges: npm @strapi/plugin-users-permissions >=4.0.0 =4.0.0 <4.13.1) Commands are suggestions: review each one before running it.
Loading voting…