Apache Ozone Improper Authentication vulnerability
CVE-2023-39196GHSA-6726-2rx3-cgwh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.ozone:ozone-main 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.ozone:ozone-main
- Affected
- >= 1.2.0, < 1.4.0
- Fixed in
- 1.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6726-2rx3-cgwh lists affected ranges: Maven org.apache.ozone:ozone-main >=1.2.0 <1.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-39196: 0.79% estimated exploitation activity in the next 30 days; percentile 56.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Authentication vulnerability in Apache Ozone. The vulnerability allows an attacker to download metadata internal to the Storage Container Manager service without proper authentication. The attacker is not allowed to do any modification within the Ozone Storage Container Manager service using this vulnerability. The accessible metadata does not contain sensitive information that can be used to exploit the system later on, and the accessible data does not make it possible to gain access to actual user data within Ozone. This issue affects Apache Ozone: 1.2.0 and subsequent releases up until 1.3.0. Users are recommended to upgrade to version 1.4.0, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6726-2rx3-cgwh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-39196 Advisory: Apache Ozone Improper Authentication vulnerability IDs: CVE-2023-39196, GHSA-6726-2rx3-cgwh Record: https://patchnext.com/advisories/cve-2023-39196 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.ozone:ozone-main 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.ozone:ozone-main: affected >= 1.2.0, < 1.4.0; fixed in 1.4.0 ## Suggested inspection (read-only) - Maven org.apache.ozone:ozone-main: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.ozone:ozone-main. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6726-2rx3-cgwh (GitHub-reviewed advisory GHSA-6726-2rx3-cgwh lists affected ranges: Maven org.apache.ozone:ozone-main >=1.2.0 <1.4.0) Commands are suggestions: review each one before running it.
Loading voting…