Skip to content

← Actionable
Critical, CVSS 9.1amended

MindsDB can be made to not verify SSL certificates

CVE-2023-38699GHSA-8hx6-qv6f-xgcw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mindsdb 23.7.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mindsdb

    Affected
    < 23.7.4.0
    Fixed in
    23.7.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2023-38699: 0.30% estimated exploitation activity in the next 30 days; percentile 22.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary MindsDB's AI Virtual Database allows developers to connect any AI/ML model to any datasource. Prior to version 23.7.4.0, a call to requests with verify=False disables SSL certificate checks. This rule enforces always verifying SSL certificates for methods in the Requests library. In version 23.7.4.0, certificates are validated by default, which is the desired behavior Encryption in general is typically critical to the security of many applications. Using TLS can significantly increase security by guaranteeing the identity of the party you are communicating with. This is accomplished by one or both parties presenting trusted certificates during the connection initialization phase of TLS. It is important to note that modules such as httplib within the Python standard library did not verify certificate chains until it was fixed in 2.7.9 release. Details Severity: Critical

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8hx6-qv6f-xgcw

  2. Revision 1 · created ·

    Published from osv record GHSA-8hx6-qv6f-xgcw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-38699

Advisory: MindsDB can be made to not verify SSL certificates
IDs: CVE-2023-38699, GHSA-8hx6-qv6f-xgcw
Record: https://patchnext.com/advisories/cve-2023-38699 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mindsdb 23.7.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mindsdb: affected < 23.7.4.0; fixed in 23.7.4.0

## Suggested inspection (read-only)
- `python -m pip show mindsdb`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mindsdb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8hx6-qv6f-xgcw (OSV record GHSA-8hx6-qv6f-xgcw lists affected ranges: PyPI mindsdb >=0 <23.7.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8hx6-qv6f-xgcw (GitHub-reviewed advisory GHSA-8hx6-qv6f-xgcw lists affected ranges: PyPI mindsdb >=0 <23.7.4.0)

Commands are suggestions: review each one before running it.

Loading voting…