Skip to content

← Actionable
Medium, CVSS 4.9amended

.eth registrar controller can shorten the duration of registered names

CVE-2023-38698GHSA-rrxv-q8m4-wch3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@ensdomains/ens-contracts 0.0.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2023-38698: 0.85% estimated exploitation activity in the next 30 days; percentile 58.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description According to the documentation, controllers are allowed to register new domains and extend the expiry of existing domains, but they cannot change the ownership or reduce the expiration time of existing domains. However, a preliminary analysis suggests that an attacker-controlled controller may be able to reduce the expiration time of existing domains due to an integer overflow in the renew function. The vulnerability resides in the following GitHub repository: https://github.com/ensdomains/ens-contracts/blob/master/contracts/ethregistrar/BaseRegistrarImplementation.sol#L171 The vulnerable line of code is: In this code snippet, the duration variable is user-supplied, making it possible to provide a value that would cause an overflow on both sides of the '' expression, ultimately rendering the condition true. Specifically, when the duration is set to 2^256 - GRACEPERIOD, the subsequent line expiries[id] += duration; also experiences an overflow, as expiries[id] is greater…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rrxv-q8m4-wch3

  2. Revision 1 · created ·

    Published from osv record GHSA-rrxv-q8m4-wch3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-38698

Advisory: .eth registrar controller can shorten the duration of registered names
IDs: CVE-2023-38698, GHSA-rrxv-q8m4-wch3
Record: https://patchnext.com/advisories/cve-2023-38698 (revision 2, source checked 26 Oct 2026, 12:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @ensdomains/ens-contracts 0.0.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @ensdomains/ens-contracts: affected <= 0.0.21; fixed in 0.0.22

## Suggested inspection (read-only)
- `npm ls @ensdomains/ens-contracts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @ensdomains/ens-contracts.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rrxv-q8m4-wch3 (OSV record GHSA-rrxv-q8m4-wch3 lists affected ranges: npm @ensdomains/ens-contracts >=0 <0.0.22 (fixed))
- Verified: https://github.com/advisories/GHSA-rrxv-q8m4-wch3 (GitHub-reviewed advisory GHSA-rrxv-q8m4-wch3 lists affected ranges: npm @ensdomains/ens-contracts >=0 <=0.0.21)

Commands are suggestions: review each one before running it.

Loading voting…