matrix-appservice-bridge doesn't verify the sub parameter of an openId token exhange, allowing unauthorized access to provisioning APIs
CVE-2023-38691GHSA-vc7j-h8xg-fv5x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-appservice-bridge 9.0.1, 8.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 4.0.0, < 8.1.2>= 9.0.0, <= 9.0.0
- Fixed in
- 8.1.2, 9.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vc7j-h8xg-fv5x lists affected ranges: npm matrix-appservice-bridge >=4.0.0 =9.0.0 <9.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vc7j-h8xg-fv5x lists affected ranges: npm matrix-appservice-bridge >=4.0.0 =9.0.0 <=9.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
- EPSS
- CVE-2023-38691: 0.47% estimated exploitation activity in the next 30 days; percentile 40.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A malicious Matrix server can use a foreign user's MXID in an OpenID exchange, allowing a bad actor to impersonate users when using the provisioning API. Details The library does not check that the servername part of the sub parameter (containing the user's claimed MXID) is the same as the servername we are talking to. A malicious actor could spin up a server on any given domain, respond with a sub parameter according to the user they want to act as and use the resulting token to perform provisioning requests. Workarounds Disable the provisioning API. If the bridge does not use the provisioning API, you are not vulnerable.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vc7j-h8xg-fv5x
- Revision 1 · created ·
Published from osv record GHSA-vc7j-h8xg-fv5x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-38691 Advisory: matrix-appservice-bridge doesn't verify the sub parameter of an openId token exhange, allowing unauthorized access to provisioning APIs IDs: CVE-2023-38691, GHSA-vc7j-h8xg-fv5x Record: https://patchnext.com/advisories/cve-2023-38691 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-appservice-bridge 9.0.1, 8.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm matrix-appservice-bridge: affected >= 4.0.0, < 8.1.2; >= 9.0.0, <= 9.0.0; fixed in 8.1.2, 9.0.1 ## Suggested inspection (read-only) - `npm ls matrix-appservice-bridge --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-appservice-bridge. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vc7j-h8xg-fv5x (OSV record GHSA-vc7j-h8xg-fv5x lists affected ranges: npm matrix-appservice-bridge >=4.0.0 =9.0.0 <9.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-vc7j-h8xg-fv5x (GitHub-reviewed advisory GHSA-vc7j-h8xg-fv5x lists affected ranges: npm matrix-appservice-bridge >=4.0.0 =9.0.0 <=9.0.0) Commands are suggestions: review each one before running it.
Loading voting…