Skip to content

← Actionable
Medium, CVSS 5.4amended

Svelecte item names vulnerable to execution of arbitrary JavaScript

CVE-2023-38687GHSA-7h45-grc5-89wq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (svelecte 3.16.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm svelecte

    Affected
    < 3.16.3
    Fixed in
    3.16.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2023-38687: 0.52% estimated exploitation activity in the next 30 days; percentile 44.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Svelecte item names are rendered as raw HTML with no escaping. This allows the injection of arbitrary HTML into the Svelecte dropdown. This can be exploited to execute arbitrary JavaScript whenever a Svelecte dropdown is opened. Details Item names given to Svelecte appear to be directly rendered as HTML by the default item renderer. This means that any HTML tags in the name are rendered as HTML elements not as text. Note that the custom item renderer shown in https://mskocik.github.io/svelecte/#item-rendering is also vulnerable to the same exploit. To prevent this all special HTML characters in item names should be escaped (for example using document.createTextNode()). PoC This code snippet demonstrates how the vulnerability can be used to execute arbitrary JavaScript without the user's knowledge when the Svelecte dropdown is opened (note that visually item 2 appears identical to other items). In this case the script is hardcoded, but in practice the real danger is that some…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7h45-grc5-89wq

  2. Revision 1 · created ·

    Published from osv record GHSA-7h45-grc5-89wq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-38687

Advisory: Svelecte item names vulnerable to execution of arbitrary JavaScript
IDs: CVE-2023-38687, GHSA-7h45-grc5-89wq
Record: https://patchnext.com/advisories/cve-2023-38687 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: svelecte 3.16.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm svelecte: affected < 3.16.3; fixed in 3.16.3

## Suggested inspection (read-only)
- `npm ls svelecte --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on svelecte.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7h45-grc5-89wq (OSV record GHSA-7h45-grc5-89wq lists affected ranges: npm svelecte >=0 <3.16.3 (fixed))
- Verified: https://github.com/advisories/GHSA-7h45-grc5-89wq (GitHub-reviewed advisory GHSA-7h45-grc5-89wq lists affected ranges: npm svelecte >=0 <3.16.3)

Commands are suggestions: review each one before running it.

Loading voting…