Skip to content

← Actionable
High, CVSS 7.3amended

Strapi Improper Rate Limiting vulnerability

CVE-2023-38507GHSA-24q2-59hm-rh9r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/plugin-users-permissions 4.12.1; @strapi/admin 4.12.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2023-38507: 0.96% estimated exploitation activity in the next 30 days; percentile 61.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

1. Summary There is a rate limit on the login function of Strapi's admin screen, but it is possible to circumvent it. 2. Details It is possible to avoid this by modifying the rate-limited request path as follows. 1. Manipulating request paths to upper or lower case. (Pattern 1) - In this case, avoidance is possible with various patterns. 2. Add path slashes to the end of the request path. (Pattern 2) 3. PoC Access the administrator's login screen (/admin/auth/login) and execute the following PoC on the browser's console screen. Pattern 1 (uppercase and lowercase) This PoC does the following: 1. Request 30 incorrect logins. 4. Execute the same request again and confirm that it is blocked by rate limit from the console screen. (429 Too Many Requests) 5. Next, falsify the pathname of the request (/admin/Login) and make a request again to confirm that it is possible to bypass the rate limit and log in. (200 OK) Pattern 2 (trailing slash) This PoC does the following: 1. Request 30…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-24q2-59hm-rh9r

  2. Revision 1 · created ·

    Published from osv record GHSA-24q2-59hm-rh9r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-38507

Advisory: Strapi Improper Rate Limiting vulnerability
IDs: CVE-2023-38507, GHSA-24q2-59hm-rh9r
Record: https://patchnext.com/advisories/cve-2023-38507 (revision 2, source checked 26 Oct 2026, 12:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @strapi/plugin-users-permissions 4.12.1; @strapi/admin 4.12.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @strapi/plugin-users-permissions: affected < 4.12.1; fixed in 4.12.1
- npm @strapi/admin: affected < 4.12.1; fixed in 4.12.1

## Suggested inspection (read-only)
- `npm ls @strapi/plugin-users-permissions --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @strapi/admin --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @strapi/plugin-users-permissions, @strapi/admin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-24q2-59hm-rh9r (OSV record GHSA-24q2-59hm-rh9r lists affected ranges: npm @strapi/admin >=0 =0 <4.12.1 (fixed))
- Verified: https://github.com/advisories/GHSA-24q2-59hm-rh9r (GitHub-reviewed advisory GHSA-24q2-59hm-rh9r lists affected ranges: npm @strapi/admin >=0 =0 <4.12.1)

Commands are suggestions: review each one before running it.

Loading voting…