Incorrect Permission Checking for GraphQL Subscriptions
CVE-2023-38503GHSA-gggm-66rh-pp98
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 10.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm directus
- Affected
- >= 10.3.0, < 10.5.0
- Fixed in
- 10.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gggm-66rh-pp98 lists affected ranges: npm directus >=10.3.0 <10.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gggm-66rh-pp98 lists affected ranges: npm directus >=10.3.0 <10.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-38503: 0.50% estimated exploitation activity in the next 30 days; percentile 42.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary CWE-200: Exposure of Sensitive Information to an Unauthorized Actor Access to information you should not have access to when the permissions rely on $CURRENTUSER for filtering. Details The permission filters (i.e. usercreated IS $CURRENTUSER) are not properly checked when using GraphQL subscription resulting in unauthorized users getting event on their subscription which they should not be receiving according to the permissions. This can be any collection but out-of-the box the directususers collection is configured with such a permissions filter allowing you to get updates for other users when changes happen. An example: Patches https://github.com/directus/directus/pull/19155 Workarounds Disable GraphQL Subscriptions References
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gggm-66rh-pp98
- Revision 1 · created ·
Published from osv record GHSA-gggm-66rh-pp98
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-38503 Advisory: Incorrect Permission Checking for GraphQL Subscriptions IDs: CVE-2023-38503, GHSA-gggm-66rh-pp98 Record: https://patchnext.com/advisories/cve-2023-38503 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: directus 10.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm directus: affected >= 10.3.0, < 10.5.0; fixed in 10.5.0 ## Suggested inspection (read-only) - `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on directus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gggm-66rh-pp98 (OSV record GHSA-gggm-66rh-pp98 lists affected ranges: npm directus >=10.3.0 <10.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-gggm-66rh-pp98 (GitHub-reviewed advisory GHSA-gggm-66rh-pp98 lists affected ranges: npm directus >=10.3.0 <10.5.0) Commands are suggestions: review each one before running it.
Loading voting…