Skip to content

← Actionable
Low, CVSS 3.7

Information Disclosure due to Out-of-scope Site Resolution

CVE-2023-38499GHSA-jq6g-4v5m-wm9r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 12.4.4, 11.5.30, 10.4.39, 9.5.42), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist typo3/cms-core

    Affected
    >= 9.4.0, < 9.5.42>= 10.0.0, < 10.4.39>= 11.0.0, < 11.5.30>= 12.0.0, < 12.4.4
    Fixed in
    9.5.42, 10.4.39, 12.4.4, 11.5.30

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2023-38499: 1.07% estimated exploitation activity in the next 30 days; percentile 64.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

CVSS: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N/E:F/RL:O/RC:C (3.5) Problem In multi-site scenarios, enumerating the HTTP query parameters id and L allowed out-of-scope access to rendered content in the website frontend. For instance, this allowed visitors to access content of an internal site by adding handcrafted query parameters to the URL of a site that was publicly available. Solution Update to TYPO3 versions 9.5.42 ELTS, 10.4.39 ELTS, 11.5.30, 12.4.4 that fix the problem described above. ℹ️ Strong security defaults - Manual actions required Resolving sites by the id and L HTTP query parameters is now denied per default. However, it is still allowed to resolve a particular page by e.g. https://example.org/?id=123&L=0 - as long as the page-id 123 is in the scope of the site configured for the base-url example.org. The new feature flag security.frontend.allowInsecureSiteResolutionByQueryParameters - which is disabled per default - can be used to reactivate the previous…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jq6g-4v5m-wm9r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-38499

Advisory: Information Disclosure due to Out-of-scope Site Resolution
IDs: CVE-2023-38499, GHSA-jq6g-4v5m-wm9r
Record: https://patchnext.com/advisories/cve-2023-38499 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 12.4.4, 11.5.30, 10.4.39, 9.5.42. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms-core: affected >= 9.4.0, < 9.5.42; >= 10.0.0, < 10.4.39; >= 11.0.0, < 11.5.30; >= 12.0.0, < 12.4.4; fixed in 9.5.42, 10.4.39, 12.4.4, 11.5.30

## Suggested inspection (read-only)
- Packagist typo3/cms-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jq6g-4v5m-wm9r (GitHub-reviewed advisory GHSA-jq6g-4v5m-wm9r lists affected ranges: Packagist typo3/cms-core >=9.4.0 =10.0.0 =11.0.0 =12.0.0 <12.4.4)

Commands are suggestions: review each one before running it.

Loading voting…