Ineffective privileges drop when requesting container network
CVE-2023-38496GHSA-mmx5-32m4-wxvx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/apptainer/apptainer 1.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/apptainer/apptainer
- Affected
- >= 1.2.0, < 1.2.1
- Fixed in
- 1.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mmx5-32m4-wxvx lists affected ranges: Go github.com/apptainer/apptainer >=1.2.0 <1.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H
- EPSS
- CVE-2023-38496: 0.26% estimated exploitation activity in the next 30 days; percentile 17.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Fix https://github.com/apptainer/apptainer/pull/1523 included in Apptainer 1.2.0-rc.2 has introduced an ineffective privilege drop when requesting container network setup, therefore subsequent functions are called with root privileges. The attack surface is rather limited for users but an attacker could possibly craft a starter config to delete any directory on the host filesystems. Only affects setuid installations of Apptainer. Patches The security fix https://github.com/apptainer/apptainer/pull/1578 has been included in Apptainer 1.2.1 Workarounds There is no known workaround outside of upgrading to Apptainer 1.2.1
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mmx5-32m4-wxvx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-38496 Advisory: Ineffective privileges drop when requesting container network IDs: CVE-2023-38496, GHSA-mmx5-32m4-wxvx Record: https://patchnext.com/advisories/cve-2023-38496 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/apptainer/apptainer 1.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/apptainer/apptainer: affected >= 1.2.0, < 1.2.1; fixed in 1.2.1 ## Suggested inspection (read-only) - Go github.com/apptainer/apptainer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/apptainer/apptainer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mmx5-32m4-wxvx (GitHub-reviewed advisory GHSA-mmx5-32m4-wxvx lists affected ranges: Go github.com/apptainer/apptainer >=1.2.0 <1.2.1) Commands are suggestions: review each one before running it.
Loading voting…