Skip to content

← Actionable
Medium, CVSS 5.3

Denial of service from unlimited password lengths

CVE-2023-38492GHSA-3v6j-v3qc-cxff

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 3.9.6, 3.8.4.1, 3.7.5.2, 3.6.6.3, 3.5.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getkirby/cms

    Affected
    < 3.5.8.3>= 3.6.0, < 3.6.6.3>= 3.7.0, < 3.7.5.2>= 3.8.0, < 3.8.4.1>= 3.9.0, < 3.9.6
    Fixed in
    3.8.4.1, 3.7.5.2, 3.6.6.3, 3.9.6, 3.5.8.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2023-38492: 1.18% estimated exploitation activity in the next 30 days; percentile 67.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

TL;DR This vulnerability affects all Kirby sites with user accounts (unless Kirby's API and Panel are disabled in the config). The real-world impact of this vulnerability is limited, however we still recommend to update to one of the patch releases because they also fix more severe vulnerabilities. ---- Introduction Denial of service (DoS) is a type of attack in which an attacker floods a service with the intention to limit performance or availability for legitimate users of the service. In the variation described in this advisory (a so called application layer denial of service attack), it is performed by causing a computationally expensive task to be run on the server. This may then cause a performance bottleneck. Impact Kirby's authentication endpoint did not limit the password length. This allowed attackers to provide a password with a length up to the server's maximum request body length. Validating that password against the user's actual password requires hashing the provided…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3v6j-v3qc-cxff

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-38492

Advisory: Denial of service from unlimited password lengths
IDs: CVE-2023-38492, GHSA-3v6j-v3qc-cxff
Record: https://patchnext.com/advisories/cve-2023-38492 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 3.9.6, 3.8.4.1, 3.7.5.2, 3.6.6.3, 3.5.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/cms: affected < 3.5.8.3; >= 3.6.0, < 3.6.6.3; >= 3.7.0, < 3.7.5.2; >= 3.8.0, < 3.8.4.1; >= 3.9.0, < 3.9.6; fixed in 3.8.4.1, 3.7.5.2, 3.6.6.3, 3.9.6, 3.5.8.3

## Suggested inspection (read-only)
- Packagist getkirby/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3v6j-v3qc-cxff (GitHub-reviewed advisory GHSA-3v6j-v3qc-cxff lists affected ranges: Packagist getkirby/cms >=0 =3.6.0 =3.7.0 =3.8.0 =3.9.0 <3.9.6)

Commands are suggestions: review each one before running it.

Loading voting…