Skip to content

← Actionable
Medium, CVSS 6.8

XML External Entity (XXE) vulnerability in the XML data handler

CVE-2023-38490GHSA-q386-w6fg-gmgp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 3.9.6, 3.8.4.1, 3.7.5.2, 3.6.6.3, 3.5.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getkirby/cms

    Affected
    < 3.5.8.3>= 3.6.0, < 3.6.6.3>= 3.7.0, < 3.7.5.2>= 3.8.0, < 3.8.4.1>= 3.9.0, < 3.9.6
    Fixed in
    3.8.4.1, 3.7.5.2, 3.6.6.3, 3.9.6, 3.5.8.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2023-38490: 1.70% estimated exploitation activity in the next 30 days; percentile 77.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

TL;DR This vulnerability only affects Kirby sites that use the Xml data handler (e.g. Data::decode($string, 'xml')) or the Xml::parse() method in site or plugin code. The Kirby core does not use any of the affected methods. If you use an affected method and cannot rule out XML input controlled by an attacker, we strongly recommend to update to a patch release. ---- Introduction XML External Entities (XXE) is a little used feature in the XML markup language that allows to include data from external files in an XML structure. If the name of the external file can be controlled by an attacker, this becomes a vulnerability that can be abused for various system impacts like the disclosure of internal or confidential data that is stored on the server (arbitrary file disclosure) or to perform network requests on behalf of the server (server-side request forgery, SSRF). Impact Kirby's Xml::parse() method used PHP's LIBXMLNOENT constant, which enabled the processing of XML external entities…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q386-w6fg-gmgp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-38490

Advisory: XML External Entity (XXE) vulnerability in the XML data handler
IDs: CVE-2023-38490, GHSA-q386-w6fg-gmgp
Record: https://patchnext.com/advisories/cve-2023-38490 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 3.9.6, 3.8.4.1, 3.7.5.2, 3.6.6.3, 3.5.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/cms: affected < 3.5.8.3; >= 3.6.0, < 3.6.6.3; >= 3.7.0, < 3.7.5.2; >= 3.8.0, < 3.8.4.1; >= 3.9.0, < 3.9.6; fixed in 3.8.4.1, 3.7.5.2, 3.6.6.3, 3.9.6, 3.5.8.3

## Suggested inspection (read-only)
- Packagist getkirby/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q386-w6fg-gmgp (GitHub-reviewed advisory GHSA-q386-w6fg-gmgp lists affected ranges: Packagist getkirby/cms >=0 =3.6.0 =3.7.0 =3.8.0 =3.9.0 <3.9.6)

Commands are suggestions: review each one before running it.

Loading voting…