Skip to content

← Actionable
High, CVSS 7.1

Field injection in the KirbyData text storage handler

CVE-2023-38488GHSA-x5mr-p6v4-wp93

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 3.9.6, 3.8.4.1, 3.7.5.2, 3.6.6.3, 3.5.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getkirby/cms

    Affected
    < 3.5.8.3>= 3.6.0, < 3.6.6.3>= 3.7.0, < 3.7.5.2>= 3.8.0, < 3.8.4.1>= 3.9.0, < 3.9.6
    Fixed in
    3.8.4.1, 3.7.5.2, 3.6.6.3, 3.9.6, 3.5.8.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
EPSS
  • CVE-2023-38488: 0.92% estimated exploitation activity in the next 30 days; percentile 60.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

TL;DR This vulnerability affects all Kirby sites that might have potential attackers in the group of authenticated Panel users or that allow external visitors to update a Kirby content file (e.g. via a contact or comment form). Your Kirby sites are not affected if they don't allow write access for untrusted users or visitors. ---- Introduction A field injection in a content storage implementation is a type of vulnerability that allows attackers with content write access to overwrite content fields that the site developer didn't intend to be modified. In a Kirby site this can be used to alter site content, break site behavior or inject malicious data or code. The exact security risk depends on the field type and usage. Impact Kirby stores content of the site, of pages, files and users in text files by default. The text files use Kirby's KirbyData format where each field is separated by newlines and a line with four dashes (----). When reading a KirbyData file, the affected code first…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x5mr-p6v4-wp93

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-38488

Advisory: Field injection in the KirbyData text storage handler
IDs: CVE-2023-38488, GHSA-x5mr-p6v4-wp93
Record: https://patchnext.com/advisories/cve-2023-38488 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 3.9.6, 3.8.4.1, 3.7.5.2, 3.6.6.3, 3.5.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/cms: affected < 3.5.8.3; >= 3.6.0, < 3.6.6.3; >= 3.7.0, < 3.7.5.2; >= 3.8.0, < 3.8.4.1; >= 3.9.0, < 3.9.6; fixed in 3.8.4.1, 3.7.5.2, 3.6.6.3, 3.9.6, 3.5.8.3

## Suggested inspection (read-only)
- Packagist getkirby/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x5mr-p6v4-wp93 (GitHub-reviewed advisory GHSA-x5mr-p6v4-wp93 lists affected ranges: Packagist getkirby/cms >=0 =3.6.0 =3.7.0 =3.8.0 =3.9.0 <3.9.6)

Commands are suggestions: review each one before running it.

Loading voting…