Skip to content

← Actionable
High, CVSS 8.7amended

cryptography mishandles SSH certificates

CVE-2023-38325GHSA-cf7p-gm2m-833m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cryptography 41.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-38325: 0.73% estimated exploitation activity in the next 30 days; percentile 54.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The cryptography package before 41.0.2 for Python mishandles SSH certificates that have critical options.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cf7p-gm2m-833m

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cf7p-gm2m-833m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-38325

Advisory: cryptography mishandles SSH certificates
IDs: CVE-2023-38325, GHSA-cf7p-gm2m-833m
Record: https://patchnext.com/advisories/cve-2023-38325 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cryptography 41.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI cryptography: affected >= 40.0.0, < 41.0.2; fixed in 41.0.2

## Suggested inspection (read-only)
- `python -m pip show cryptography`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cryptography.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cf7p-gm2m-833m (OSV record GHSA-cf7p-gm2m-833m lists affected ranges: PyPI cryptography >=40.0.0 <41.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-cf7p-gm2m-833m (GitHub-reviewed advisory GHSA-cf7p-gm2m-833m lists affected ranges: PyPI cryptography >=40.0.0 <41.0.2)

Commands are suggestions: review each one before running it.

Loading voting…