Skip to content

← Actionable
Medium, CVSS 6.3

Magento Open Source allows Incorrect Authorization

CVE-2023-38218GHSA-rpc7-gf58-v3x2

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist magento/project-community-edition

    Affected
    <= 2.0.2
    Fixed in
    no fixed version recorded
  • Packagist magento/community-edition

    Affected
    >= 2.4.7-beta1, <= 2.4.7-beta1>= 2.4.6, <= 2.4.6>= 2.4.5, <= 2.4.5>= 2.4.4, <= 2.4.4>= 2.4.6-p1, < 2.4.6-p3>= 2.4.5-p1, < 2.4.5-p5>= 2.4.4-p1, < 2.4.4-p6
    Fixed in
    2.4.6-p3, 2.4.4-p6, 2.4.7-beta2, 2.4.5-p5

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-rpc7-gf58-v3x2 lists affected ranges: Packagist magento/community-edition >=2.4.7-beta1 =2.4.6 =2.4.5 =2.4.4 =2.4.6-p1 =2.4.5-p1 =2.4.4-p1 =0 <=2.0.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2023-38218: 0.88% estimated exploitation activity in the next 30 days; percentile 59.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Adobe Commerce versions 2.4.7-beta1 (and earlier), 2.4.6-p2 (and earlier), 2.4.5-p4 (and earlier) and 2.4.4-p5 (and earlier) are affected by an improper input validation vulnerability. An authenticated attacker can trigger an insecure direct object reference in the V1/customers/me endpoint to achieve information exposure and privilege escalation.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rpc7-gf58-v3x2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-38218

Advisory: Magento Open Source allows Incorrect Authorization
IDs: CVE-2023-38218, GHSA-rpc7-gf58-v3x2
Record: https://patchnext.com/advisories/cve-2023-38218 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: magento/community-edition 2.4.7-beta2, 2.4.6-p3, 2.4.5-p5, 2.4.4-p6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist magento/project-community-edition: affected <= 2.0.2
- Packagist magento/community-edition: affected >= 2.4.7-beta1, <= 2.4.7-beta1; >= 2.4.6, <= 2.4.6; >= 2.4.5, <= 2.4.5; >= 2.4.4, <= 2.4.4; >= 2.4.6-p1, < 2.4.6-p3; >= 2.4.5-p1, < 2.4.5-p5; >= 2.4.4-p1, < 2.4.4-p6; fixed in 2.4.6-p3, 2.4.4-p6, 2.4.7-beta2, 2.4.5-p5

## Suggested inspection (read-only)
- Packagist magento/project-community-edition: check the installed version with your package manager.
- Packagist magento/community-edition: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on magento/project-community-edition, magento/community-edition.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rpc7-gf58-v3x2 (GitHub-reviewed advisory GHSA-rpc7-gf58-v3x2 lists affected ranges: Packagist magento/community-edition >=2.4.7-beta1 =2.4.6 =2.4.5 =2.4.4 =2.4.6-p1 =2.4.5-p1 =2.4.4-p1 =0 <=2.0.2)

Commands are suggestions: review each one before running it.

Loading voting…