Keylime registrar and (untrusted) Agent can be bypassed by an attacker
CVE-2023-38201GHSA-f4r5-q63f-gcww
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (keylime 7.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI keylime
- Affected
- < 7.5.0
- Fixed in
- 7.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f4r5-q63f-gcww lists affected ranges: PyPI keylime >=0 <7.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f4r5-q63f-gcww lists affected ranges: PyPI keylime >=0 <7.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-38201: 0.49% estimated exploitation activity in the next 30 days; percentile 42.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A security issue was found in the Keylime registrar code which allows an attacker to effectively bypass the challenge-response protocol used to verify that an agent has indeed access to an AIK which in indeed related to the EK. When an agent starts up, it will contact a registrar and provide a public EK and public AIK, in addition to the EK Certificate. This registrar will then challenge the agent to decrypt a challenge encrypted with the EK. When receiving the wrong "authtag" back from the agent during activation, the registrar answers with an error message that contains the expected correct "authtag" (an HMAC which is calculated within the registrar for checking). An attacker could simply record the correct expected "authtag" from the HTTP error message and perform the activate call again with the correct expected "authtag" for the agent. The security issue allows an attacker to pass the challenge-response protocol during registration with (almost) arbitrary registration…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-f4r5-q63f-gcww
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-f4r5-q63f-gcww
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-38201 Advisory: Keylime registrar and (untrusted) Agent can be bypassed by an attacker IDs: CVE-2023-38201, GHSA-f4r5-q63f-gcww Record: https://patchnext.com/advisories/cve-2023-38201 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: keylime 7.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI keylime: affected < 7.5.0; fixed in 7.5.0 ## Suggested inspection (read-only) - `python -m pip show keylime`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on keylime. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f4r5-q63f-gcww (OSV record GHSA-f4r5-q63f-gcww lists affected ranges: PyPI keylime >=0 <7.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-f4r5-q63f-gcww (GitHub-reviewed advisory GHSA-f4r5-q63f-gcww lists affected ranges: PyPI keylime >=0 <7.5.0) Commands are suggestions: review each one before running it.
Loading voting…