Jenkins mabl Plugin vulnerable to cross-site request forgery
CVE-2023-37952GHSA-wvgr-5wgr-c6fj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.mabl.integration.jenkins:mabl-integration 0.0.47), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.mabl.integration.jenkins:mabl-integration
- Affected
- < 0.0.47
- Fixed in
- 0.0.47
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wvgr-5wgr-c6fj lists affected ranges: Maven com.mabl.integration.jenkins:mabl-integration >=0 <0.0.47
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2023-37952: 0.44% estimated exploitation activity in the next 30 days; percentile 38.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins mabl Plugin 0.0.46 and earlier does not perform permission checks in several HTTP endpoints. This allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. Additionally, these HTTP endpoints do not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability. mabl Plugin 0.0.47 requires POST requests and the appropriate permissions for the affected HTTP endpoints.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wvgr-5wgr-c6fj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-37952 Advisory: Jenkins mabl Plugin vulnerable to cross-site request forgery IDs: CVE-2023-37952, GHSA-wvgr-5wgr-c6fj Record: https://patchnext.com/advisories/cve-2023-37952 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.mabl.integration.jenkins:mabl-integration 0.0.47. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.mabl.integration.jenkins:mabl-integration: affected < 0.0.47; fixed in 0.0.47 ## Suggested inspection (read-only) - Maven com.mabl.integration.jenkins:mabl-integration: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.mabl.integration.jenkins:mabl-integration. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wvgr-5wgr-c6fj (GitHub-reviewed advisory GHSA-wvgr-5wgr-c6fj lists affected ranges: Maven com.mabl.integration.jenkins:mabl-integration >=0 <0.0.47) Commands are suggestions: review each one before running it.
Loading voting…