Jenkins Active Directory Plugin vulnerable to Active Directory credential disclosure
CVE-2023-37943GHSA-g8c3-6fj2-87w7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:active-directory 2.30.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:active-directory
- Affected
- < 2.30.1
- Fixed in
- 2.30.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g8c3-6fj2-87w7 lists affected ranges: Maven org.jenkins-ci.plugins:active-directory >=0 <2.30.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-37943: 0.46% estimated exploitation activity in the next 30 days; percentile 39.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Active Directory Plugin allows testing a new, unsaved configuration by performing a connection test (the button labeled "Test Domain"). Active Directory Plugin 2.30 and earlier ignores the "Require TLS" and "StartTls" options and always performs the connection test to Active directory unencrypted. This allows attackers able to capture network traffic between the Jenkins controller and Active Directory servers to obtain Active Directory credentials. This only affects the connection test. Connections established during the login process are encrypted if the corresponding TLS option is enabled. Active Directory Plugin 2.30.1 considers the "Require TLS" and "StartTls" options for connection tests.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g8c3-6fj2-87w7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-37943 Advisory: Jenkins Active Directory Plugin vulnerable to Active Directory credential disclosure IDs: CVE-2023-37943, GHSA-g8c3-6fj2-87w7 Record: https://patchnext.com/advisories/cve-2023-37943 (revision 1, source checked 26 Oct 2026, 16:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:active-directory 2.30.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:active-directory: affected < 2.30.1; fixed in 2.30.1 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:active-directory: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:active-directory. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g8c3-6fj2-87w7 (GitHub-reviewed advisory GHSA-g8c3-6fj2-87w7 lists affected ranges: Maven org.jenkins-ci.plugins:active-directory >=0 <2.30.1) Commands are suggestions: review each one before running it.
Loading voting…